summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-01-24 09:13:59 +0000
committerTorsten Veller <tove@gentoo.org>2006-01-24 09:13:59 +0000
commit793d9bd68e0e913ef169145d8500be06ea4464c7 (patch)
tree5de78beacb5a6916b7eac2ec6e923d9342cc7849 /x11-wm/wmii/wmii-2.ebuild
parentVersion bump, removing older ~arch versions. (diff)
downloadgentoo-2-793d9bd68e0e913ef169145d8500be06ea4464c7.tar.gz
gentoo-2-793d9bd68e0e913ef169145d8500be06ea4464c7.tar.bz2
gentoo-2-793d9bd68e0e913ef169145d8500be06ea4464c7.zip
Removed old version. Added support for modular X.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'x11-wm/wmii/wmii-2.ebuild')
-rw-r--r--x11-wm/wmii/wmii-2.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/x11-wm/wmii/wmii-2.ebuild b/x11-wm/wmii/wmii-2.ebuild
index 626dcc4f0fa5..f44c5ba5f0e5 100644
--- a/x11-wm/wmii/wmii-2.ebuild
+++ b/x11-wm/wmii/wmii-2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/wmii-2.ebuild,v 1.1 2005/08/12 15:36:22 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/wmii-2.ebuild,v 1.2 2006/01/24 09:13:59 tove Exp $
inherit eutils toolchain-funcs
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~x86"
IUSE="python"
-DEPEND="virtual/x11
+DEPEND="|| ( x11-libs/libX11 virtual/x11 )
python? ( dev-python/pyrex )"
src_unpack() {
@@ -36,7 +36,7 @@ src_unpack() {
src_compile() {
emake || die "emake failed"
- if useq python ; then
+ if use python ; then
cd "${S}"/libixp/python
python setup.py build || die "python build failed."
fi
@@ -48,16 +48,11 @@ src_install() {
dodoc ANNOUNCE || die "ANNOUNCE failed." # only in releases
dodoc CHANGES README LICENSE doc/welcome.txt || die "dodoc failed."
- if useq python ; then
+ if use python ; then
cd "${S}"/libixp/python
python setup.py install --root="${D}" || die "python install failed."
fi
-# insinto /usr/share/"${PN}"/contrib
-# doins "${S}"/contrib/README || die "contrib README failed."
-# exeinto /usr/share/"${PN}"/contrib
-# doexe "${S}"/contrib/*.py || die "contrib failed."
-
echo -e "#!/bin/sh\n/usr/bin/wmii" > "${T}/${PN}"
exeinto /etc/X11/Sessions
doexe "${T}/${PN}" || die "/etc/X11/Sessions failed."