summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-31 12:29:29 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-31 12:29:29 +0000
commit1b877fda4ed4a7fafd435c089284314481c79b72 (patch)
tree795ffcf2bd12160b225805542679e724fc40f61b /x11-wm/parti
parentold (diff)
downloadgentoo-2-1b877fda4ed4a7fafd435c089284314481c79b72.tar.gz
gentoo-2-1b877fda4ed4a7fafd435c089284314481c79b72.tar.bz2
gentoo-2-1b877fda4ed4a7fafd435c089284314481c79b72.zip
Added LiveVCS ebuild
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/parti')
-rw-r--r--x11-wm/parti/ChangeLog8
-rw-r--r--x11-wm/parti/files/parti-9999-constants.pxi287
-rw-r--r--x11-wm/parti/parti-9999.ebuild47
3 files changed, 341 insertions, 1 deletions
diff --git a/x11-wm/parti/ChangeLog b/x11-wm/parti/ChangeLog
index b91123bd8d59..9cc3b1c65fa8 100644
--- a/x11-wm/parti/ChangeLog
+++ b/x11-wm/parti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/parti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/ChangeLog,v 1.1 2010/08/31 09:04:56 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/ChangeLog,v 1.2 2010/08/31 12:29:29 xmw Exp $
+
+*parti-9999 (31 Aug 2010)
+
+ 31 Aug 2010; Michael Weber <xmw@gentoo.org> +parti-9999.ebuild,
+ +files/parti-9999-constants.pxi:
+ Added LiveVCS ebuild, needs wimpiggy/lowlevel/constants.pxi.
*parti-0.0.6 (31 Aug 2010)
diff --git a/x11-wm/parti/files/parti-9999-constants.pxi b/x11-wm/parti/files/parti-9999-constants.pxi
new file mode 100644
index 000000000000..854026807c57
--- /dev/null
+++ b/x11-wm/parti/files/parti-9999-constants.pxi
@@ -0,0 +1,287 @@
+cdef extern from *:
+ unsigned int XNone "None"
+ unsigned int PointerWindow
+ unsigned int InputFocus
+ unsigned int PointerRoot
+ unsigned int CurrentTime
+ unsigned int IsUnmapped
+ unsigned int IsUnviewable
+ unsigned int IsViewable
+ unsigned int NoEventMask
+ unsigned int KeyPressMask
+ unsigned int KeyReleaseMask
+ unsigned int ButtonPressMask
+ unsigned int ButtonReleaseMask
+ unsigned int EnterWindowMask
+ unsigned int LeaveWindowMask
+ unsigned int PointerMotionMask
+ unsigned int PointerMotionHintMask
+ unsigned int Button1MotionMask
+ unsigned int Button2MotionMask
+ unsigned int Button3MotionMask
+ unsigned int Button4MotionMask
+ unsigned int Button5MotionMask
+ unsigned int ButtonMotionMask
+ unsigned int KeymapStateMask
+ unsigned int ExposureMask
+ unsigned int VisibilityChangeMask
+ unsigned int StructureNotifyMask
+ unsigned int ResizeRedirectMask
+ unsigned int SubstructureNotifyMask
+ unsigned int SubstructureRedirectMask
+ unsigned int FocusChangeMask
+ unsigned int PropertyChangeMask
+ unsigned int ColormapChangeMask
+ unsigned int OwnerGrabButtonMask
+ unsigned int KeyPress
+ unsigned int KeyRelease
+ unsigned int ButtonPress
+ unsigned int ButtonRelease
+ unsigned int MotionNotify
+ unsigned int EnterNotify
+ unsigned int LeaveNotify
+ unsigned int FocusIn
+ unsigned int FocusOut
+ unsigned int KeymapNotify
+ unsigned int Expose
+ unsigned int GraphicsExpose
+ unsigned int NoExpose
+ unsigned int VisibilityNotify
+ unsigned int CreateNotify
+ unsigned int DestroyNotify
+ unsigned int UnmapNotify
+ unsigned int MapNotify
+ unsigned int MapRequest
+ unsigned int ReparentNotify
+ unsigned int ConfigureNotify
+ unsigned int ConfigureRequest
+ unsigned int GravityNotify
+ unsigned int ResizeRequest
+ unsigned int CirculateNotify
+ unsigned int CirculateRequest
+ unsigned int PropertyNotify
+ unsigned int SelectionClear
+ unsigned int SelectionRequest
+ unsigned int SelectionNotify
+ unsigned int ColormapNotify
+ unsigned int ClientMessage
+ unsigned int MappingNotify
+ unsigned int LASTEvent
+ unsigned int PropModeReplace
+ unsigned int PropModePrepend
+ unsigned int PropModeAppend
+ unsigned int CWX
+ unsigned int CWY
+ unsigned int CWWidth
+ unsigned int CWHeight
+ unsigned int CWBorderWidth
+ unsigned int CWSibling
+ unsigned int CWStackMode
+ unsigned int Above
+ unsigned int Below
+ unsigned int BottomIf
+ unsigned int TopIf
+ unsigned int Opposite
+ unsigned int Success
+ unsigned int BadRequest
+ unsigned int BadValue
+ unsigned int BadWindow
+ unsigned int BadPixmap
+ unsigned int BadAtom
+ unsigned int BadCursor
+ unsigned int BadFont
+ unsigned int BadMatch
+ unsigned int BadDrawable
+ unsigned int BadAccess
+ unsigned int BadAlloc
+ unsigned int BadColor
+ unsigned int BadGC
+ unsigned int BadIDChoice
+ unsigned int BadName
+ unsigned int BadLength
+ unsigned int BadImplementation
+ unsigned int FirstExtensionError
+ unsigned int LastExtensionError
+ unsigned int USPosition
+ unsigned int USSize
+ unsigned int PPosition
+ unsigned int PSize
+ unsigned int PMinSize
+ unsigned int PMaxSize
+ unsigned int PResizeInc
+ unsigned int PAspect
+ unsigned int PBaseSize
+ unsigned int PWinGravity
+ unsigned int InputHint
+ unsigned int StateHint
+ unsigned int IconPixmapHint
+ unsigned int IconWindowHint
+ unsigned int IconPositionHint
+ unsigned int IconMaskHint
+ unsigned int WindowGroupHint
+ unsigned int XUrgencyHint
+ unsigned int WithdrawnState
+ unsigned int NormalState
+ unsigned int IconicState
+ unsigned int RevertToParent
+ unsigned int RevertToPointerRoot
+ unsigned int RevertToNone
+ unsigned int NotifyNormal
+ unsigned int NotifyGrab
+ unsigned int NotifyUngrab
+ unsigned int NotifyAncestor
+ unsigned int NotifyVirtual
+ unsigned int NotifyInferior
+ unsigned int NotifyNonlinear
+ unsigned int NotifyNonlinearVirtual
+ unsigned int NotifyPointer
+ unsigned int NotifyPointerRoot
+ unsigned int NotifyDetailNone
+ unsigned int GrabModeSync
+ unsigned int GrabModeAsync
+ unsigned int AnyKey
+ unsigned int AnyModifier
+const = {
+ "XNone": XNone,
+ "PointerWindow": PointerWindow,
+ "InputFocus": InputFocus,
+ "PointerRoot": PointerRoot,
+ "CurrentTime": CurrentTime,
+ "IsUnmapped": IsUnmapped,
+ "IsUnviewable": IsUnviewable,
+ "IsViewable": IsViewable,
+ "NoEventMask": NoEventMask,
+ "KeyPressMask": KeyPressMask,
+ "KeyReleaseMask": KeyReleaseMask,
+ "ButtonPressMask": ButtonPressMask,
+ "ButtonReleaseMask": ButtonReleaseMask,
+ "EnterWindowMask": EnterWindowMask,
+ "LeaveWindowMask": LeaveWindowMask,
+ "PointerMotionMask": PointerMotionMask,
+ "PointerMotionHintMask": PointerMotionHintMask,
+ "Button1MotionMask": Button1MotionMask,
+ "Button2MotionMask": Button2MotionMask,
+ "Button3MotionMask": Button3MotionMask,
+ "Button4MotionMask": Button4MotionMask,
+ "Button5MotionMask": Button5MotionMask,
+ "ButtonMotionMask": ButtonMotionMask,
+ "KeymapStateMask": KeymapStateMask,
+ "ExposureMask": ExposureMask,
+ "VisibilityChangeMask": VisibilityChangeMask,
+ "StructureNotifyMask": StructureNotifyMask,
+ "ResizeRedirectMask": ResizeRedirectMask,
+ "SubstructureNotifyMask": SubstructureNotifyMask,
+ "SubstructureRedirectMask": SubstructureRedirectMask,
+ "FocusChangeMask": FocusChangeMask,
+ "PropertyChangeMask": PropertyChangeMask,
+ "ColormapChangeMask": ColormapChangeMask,
+ "OwnerGrabButtonMask": OwnerGrabButtonMask,
+ "KeyPress": KeyPress,
+ "KeyRelease": KeyRelease,
+ "ButtonPress": ButtonPress,
+ "ButtonRelease": ButtonRelease,
+ "MotionNotify": MotionNotify,
+ "EnterNotify": EnterNotify,
+ "LeaveNotify": LeaveNotify,
+ "FocusIn": FocusIn,
+ "FocusOut": FocusOut,
+ "KeymapNotify": KeymapNotify,
+ "Expose": Expose,
+ "GraphicsExpose": GraphicsExpose,
+ "NoExpose": NoExpose,
+ "VisibilityNotify": VisibilityNotify,
+ "CreateNotify": CreateNotify,
+ "DestroyNotify": DestroyNotify,
+ "UnmapNotify": UnmapNotify,
+ "MapNotify": MapNotify,
+ "MapRequest": MapRequest,
+ "ReparentNotify": ReparentNotify,
+ "ConfigureNotify": ConfigureNotify,
+ "ConfigureRequest": ConfigureRequest,
+ "GravityNotify": GravityNotify,
+ "ResizeRequest": ResizeRequest,
+ "CirculateNotify": CirculateNotify,
+ "CirculateRequest": CirculateRequest,
+ "PropertyNotify": PropertyNotify,
+ "SelectionClear": SelectionClear,
+ "SelectionRequest": SelectionRequest,
+ "SelectionNotify": SelectionNotify,
+ "ColormapNotify": ColormapNotify,
+ "ClientMessage": ClientMessage,
+ "MappingNotify": MappingNotify,
+ "LASTEvent": LASTEvent,
+ "PropModeReplace": PropModeReplace,
+ "PropModePrepend": PropModePrepend,
+ "PropModeAppend": PropModeAppend,
+ "CWX": CWX,
+ "CWY": CWY,
+ "CWWidth": CWWidth,
+ "CWHeight": CWHeight,
+ "CWBorderWidth": CWBorderWidth,
+ "CWSibling": CWSibling,
+ "CWStackMode": CWStackMode,
+ "Above": Above,
+ "Below": Below,
+ "BottomIf": BottomIf,
+ "TopIf": TopIf,
+ "Opposite": Opposite,
+ "Success": Success,
+ "BadRequest": BadRequest,
+ "BadValue": BadValue,
+ "BadWindow": BadWindow,
+ "BadPixmap": BadPixmap,
+ "BadAtom": BadAtom,
+ "BadCursor": BadCursor,
+ "BadFont": BadFont,
+ "BadMatch": BadMatch,
+ "BadDrawable": BadDrawable,
+ "BadAccess": BadAccess,
+ "BadAlloc": BadAlloc,
+ "BadColor": BadColor,
+ "BadGC": BadGC,
+ "BadIDChoice": BadIDChoice,
+ "BadName": BadName,
+ "BadLength": BadLength,
+ "BadImplementation": BadImplementation,
+ "FirstExtensionError": FirstExtensionError,
+ "LastExtensionError": LastExtensionError,
+ "USPosition": USPosition,
+ "USSize": USSize,
+ "PPosition": PPosition,
+ "PSize": PSize,
+ "PMinSize": PMinSize,
+ "PMaxSize": PMaxSize,
+ "PResizeInc": PResizeInc,
+ "PAspect": PAspect,
+ "PBaseSize": PBaseSize,
+ "PWinGravity": PWinGravity,
+ "InputHint": InputHint,
+ "StateHint": StateHint,
+ "IconPixmapHint": IconPixmapHint,
+ "IconWindowHint": IconWindowHint,
+ "IconPositionHint": IconPositionHint,
+ "IconMaskHint": IconMaskHint,
+ "WindowGroupHint": WindowGroupHint,
+ "XUrgencyHint": XUrgencyHint,
+ "WithdrawnState": WithdrawnState,
+ "NormalState": NormalState,
+ "IconicState": IconicState,
+ "RevertToParent": RevertToParent,
+ "RevertToPointerRoot": RevertToPointerRoot,
+ "RevertToNone": RevertToNone,
+ "NotifyNormal": NotifyNormal,
+ "NotifyGrab": NotifyGrab,
+ "NotifyUngrab": NotifyUngrab,
+ "NotifyAncestor": NotifyAncestor,
+ "NotifyVirtual": NotifyVirtual,
+ "NotifyInferior": NotifyInferior,
+ "NotifyNonlinear": NotifyNonlinear,
+ "NotifyNonlinearVirtual": NotifyNonlinearVirtual,
+ "NotifyPointer": NotifyPointer,
+ "NotifyPointerRoot": NotifyPointerRoot,
+ "NotifyDetailNone": NotifyDetailNone,
+ "GrabModeSync": GrabModeSync,
+ "GrabModeAsync": GrabModeAsync,
+ "AnyKey": AnyKey,
+ "AnyModifier": AnyModifier,
+}
diff --git a/x11-wm/parti/parti-9999.ebuild b/x11-wm/parti/parti-9999.ebuild
new file mode 100644
index 000000000000..fdba3722861f
--- /dev/null
+++ b/x11-wm/parti/parti-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/parti-9999.ebuild,v 1.1 2010/08/31 12:29:29 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND=2
+
+inherit distutils eutils mercurial python
+
+EHG_REPO_URI="https://partiwm.googlecode.com/hg/"
+
+DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
+HOMEPAGE="http://partiwm.googlecode.com/"
+MY_P="${PN}-all-${PV}"
+SRC_URI=""
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+COMMON_DEPEND="dev-python/pygtk
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXtst"
+
+RDEPEND="${COMMON_RDEPEND}
+ dev-python/ipython
+ x11-apps/xmodmap"
+DEPEND="${COMMON_RDEPEND}
+ dev-python/cython
+ dev-python/pyrex
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/hg
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ if [ ! -e wimpiggy/lowlevel/constants.pxi ] ; then
+ cp "${FILESDIR}"/${P}-constants.pxi wimpiggy/lowlevel/constants.pxi || die
+ fi
+}