summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-10-07 10:25:13 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-10-07 10:25:13 +0000
commit40dbd10ea20fa6d38380dbb79190878b771129ae (patch)
treeba89708fb9e4f1bae226434cea49e382ebd6836b /x11-wm/icewm
parentDrop maintainer due retirement, #274113 (diff)
downloadgentoo-2-40dbd10ea20fa6d38380dbb79190878b771129ae.tar.gz
gentoo-2-40dbd10ea20fa6d38380dbb79190878b771129ae.tar.bz2
gentoo-2-40dbd10ea20fa6d38380dbb79190878b771129ae.zip
Fix building with gcc-4.7 wrt #424888 by Diego Elio Pettenò <flameeyes@gentoo.org>. Thanks to Jernej Simoncic <jernej.bz1-gentoo@ena.si> for scavenging patch
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog8
-rw-r--r--x11-wm/icewm/files/icewm-1.3.7-gcc47.patch14
-rw-r--r--x11-wm/icewm/icewm-1.3.7.ebuild5
3 files changed, 24 insertions, 3 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index f4302c6bbb3b..645505cdc289 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/icewm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.149 2012/06/16 13:26:14 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.150 2012/10/07 10:25:13 xarthisius Exp $
+
+ 07 Oct 2012; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/icewm-1.3.7-gcc47.patch, icewm-1.3.7.ebuild:
+ Fix building with gcc-4.7 wrt #424888 by Diego Elio Pettenò
+ <flameeyes@gentoo.org>. Thanks to Jernej Simoncic <jernej.bz1-gentoo@ena.si>
+ for scavenging patch
16 Jun 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+files/icewm-1.2.37-libX11-1.5.0-deprecated.patch, icewm-1.2.37.ebuild,
diff --git a/x11-wm/icewm/files/icewm-1.3.7-gcc47.patch b/x11-wm/icewm/files/icewm-1.3.7-gcc47.patch
new file mode 100644
index 000000000000..c33adda1e982
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.7-gcc47.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/show_bug.cgi?id=424888
+http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672089#24
+
+--- a/src/yarray.h
++++ b/src/yarray.h
+@@ -152,7 +152,7 @@ public:
+ }
+
+ virtual void remove(const typename YArray<DataType *>::SizeType index) {
+- if (index < YArray<DataType *>::getCount()) delete getItem(index);
++ if (index < YArray<DataType *>::getCount()) delete this->getItem(index);
+ YArray<DataType *>::remove(index);
+ }
+
diff --git a/x11-wm/icewm/icewm-1.3.7.ebuild b/x11-wm/icewm/icewm-1.3.7.ebuild
index 5b235ad2e1e3..71507e13a3f4 100644
--- a/x11-wm/icewm/icewm-1.3.7.ebuild
+++ b/x11-wm/icewm/icewm-1.3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.3.7.ebuild,v 1.4 2012/06/16 13:26:14 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.3.7.ebuild,v 1.5 2012/10/07 10:25:13 xarthisius Exp $
EAPI="4"
@@ -46,7 +46,8 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-gcc44.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
cd "${S}/src"
use uclibc && epatch "${FILESDIR}/${PN}-uclibc.patch"
# build fix for libX11-1.5.0, bug 420773