summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-02-07 20:47:59 +0000
committerCédric Krier <cedk@gentoo.org>2007-02-07 20:47:59 +0000
commitb74c1754cb540a83f4b7d66d561ab7729e8f41be (patch)
tree9b4a331e360a2700295ff22ed734b22f1fa6682f /x11-wm/dwm
parentDep for new pending package mail-filter/spamassassin-fuzzyocr; bug #158445 (diff)
downloadgentoo-2-b74c1754cb540a83f4b7d66d561ab7729e8f41be.tar.gz
gentoo-2-b74c1754cb540a83f4b7d66d561ab7729e8f41be.tar.bz2
gentoo-2-b74c1754cb540a83f4b7d66d561ab7729e8f41be.zip
x11-wm/dwm: Version bump and add eclass savedconfig
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/ChangeLog8
-rw-r--r--x11-wm/dwm/dwm-3.4.ebuild70
-rw-r--r--x11-wm/dwm/files/digest-dwm-3.43
3 files changed, 80 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index b34aa34ca947..1d8e30a6a4c7 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.11 2007/02/01 19:44:06 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.12 2007/02/07 20:47:59 cedk Exp $
+
+*dwm-3.4 (07 Feb 2007)
+
+ 07 Feb 2007; Cedric Krier <cedk@gentoo.org> -dwm-3.2.2.ebuild,
+ +dwm-3.4.ebuild:
+ Version bump and add eclass savedconfig
*dwm-3.3 (01 Feb 2007)
diff --git a/x11-wm/dwm/dwm-3.4.ebuild b/x11-wm/dwm/dwm-3.4.ebuild
new file mode 100644
index 000000000000..83632c8e3b8a
--- /dev/null
+++ b/x11-wm/dwm/dwm-3.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-3.4.ebuild,v 1.1 2007/02/07 20:47:59 cedk Exp $
+
+inherit toolchain-funcs savedconfig
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://dwm.suckless.org/"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ restore_config config.h
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-3.4 b/x11-wm/dwm/files/digest-dwm-3.4
new file mode 100644
index 000000000000..00742491514a
--- /dev/null
+++ b/x11-wm/dwm/files/digest-dwm-3.4
@@ -0,0 +1,3 @@
+MD5 fb4ca53999b4c830b8e5e5c73e93deac dwm-3.4.tar.gz 17532
+RMD160 cfffce02be942ef19d2bc4b030ef4acae30141e2 dwm-3.4.tar.gz 17532
+SHA256 654b300a8e63b8a88f93b304e08a50bae2d4261c8e9570a46aaa3d4f1675e4bb dwm-3.4.tar.gz 17532