summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-04-01 11:29:45 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-04-01 11:29:45 +0000
commitf43d31b49b120d78ef40eeb36fbda2f0b7b935bc (patch)
tree5b5e68034f2253e96b0c5e16b9025288a83428aa /x11-themes
parentFixed Typo in USE description (diff)
downloadgentoo-2-f43d31b49b120d78ef40eeb36fbda2f0b7b935bc.tar.gz
gentoo-2-f43d31b49b120d78ef40eeb36fbda2f0b7b935bc.tar.bz2
gentoo-2-f43d31b49b120d78ef40eeb36fbda2f0b7b935bc.zip
Bump to 2.91.93
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-icon-theme/ChangeLog8
-rw-r--r--x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.93.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/x11-themes/gnome-icon-theme/ChangeLog b/x11-themes/gnome-icon-theme/ChangeLog
index 12c7340537eb..ebbff9d9ad35 100644
--- a/x11-themes/gnome-icon-theme/ChangeLog
+++ b/x11-themes/gnome-icon-theme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gnome-icon-theme
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/ChangeLog,v 1.196 2011/03/23 05:08:19 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/ChangeLog,v 1.197 2011/04/01 11:29:45 nirbheek Exp $
+
+*gnome-icon-theme-2.91.93 (01 Apr 2011)
+
+ 01 Apr 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +gnome-icon-theme-2.91.93.ebuild:
+ Bump to 2.91.93
*gnome-icon-theme-2.91.92 (23 Mar 2011)
diff --git a/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.93.ebuild b/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.93.ebuild
new file mode 100644
index 000000000000..b0280268de73
--- /dev/null
+++ b/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.93.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-icon-theme/gnome-icon-theme-2.91.93.ebuild,v 1.1 2011/04/01 11:29:45 nirbheek Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="GNOME default icon themes"
+HOMEPAGE="http://www.gnome.org/ http://people.freedesktop.org/~jimmac/icons/#git"
+
+SRC_URI="${SRC_URI}
+ branding? ( http://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )"
+
+LICENSE="LGPL-3 CCPL-Attribution-ShareAlike-3.0
+ branding? ( CCPL-Sampling-Plus-1.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="branding"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+DEPEND="${RDEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.40
+ sys-devel/gettext"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+# FIXME: double check potential LINGUAS problem
+pkg_setup() {
+ DOCS="AUTHORS NEWS TODO"
+ G2CONF="${G2CONF} --enable-icon-mapping"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if use branding; then
+ for i in 16 22 24 32 48; do
+ cp "${WORKDIR}"/tango-gentoo-v1.1/${i}x${i}/gentoo.png \
+ "${S}"/gnome//${i}x${i}/places/start-here.png \
+ || die "Copying gentoo logos failed"
+ done
+ fi
+
+ # Revert upstream commit that is wrongly updating icon cache, upstream bug #642449
+ EPATCH_OPTS="-R" epatch "${FILESDIR}/${PN}-2.91.7-update-cache.patch"
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}