summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-20 09:06:46 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-20 09:06:46 +0000
commit477950f2a5f3dfa822a44989f5ae4849377f344d (patch)
tree20de042d2f28f4f54f7e72f8544f1e0be5386c35 /x11-themes
parentInitial import (bug #302658). (diff)
downloadgentoo-2-477950f2a5f3dfa822a44989f5ae4849377f344d.tar.gz
gentoo-2-477950f2a5f3dfa822a44989f5ae4849377f344d.tar.bz2
gentoo-2-477950f2a5f3dfa822a44989f5ae4849377f344d.zip
Version bump to latest. Stabilise 1.0.4 on amd64 and x86.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/oxygen-gtk/ChangeLog8
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild4
-rw-r--r--x11-themes/oxygen-gtk/oxygen-gtk-1.0.5.ebuild44
3 files changed, 53 insertions, 3 deletions
diff --git a/x11-themes/oxygen-gtk/ChangeLog b/x11-themes/oxygen-gtk/ChangeLog
index c20bb94c4706..370c87c87023 100644
--- a/x11-themes/oxygen-gtk/ChangeLog
+++ b/x11-themes/oxygen-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/oxygen-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.8 2011/04/16 09:11:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/ChangeLog,v 1.9 2011/05/20 09:06:46 scarabeus Exp $
+
+*oxygen-gtk-1.0.5 (20 May 2011)
+
+ 20 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> oxygen-gtk-1.0.4.ebuild,
+ +oxygen-gtk-1.0.5.ebuild:
+ Version bump to latest. Stabilise 1.0.4 on amd64 and x86.
*oxygen-gtk-1.0.4 (16 Apr 2011)
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild
index 8bf90ede9fa9..3014702d28bb 100644
--- a/x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild,v 1.1 2011/04/16 09:11:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.0.4.ebuild,v 1.2 2011/05/20 09:06:46 scarabeus Exp $
EAPI=4
@@ -11,7 +11,7 @@ HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
SLOT="0"
IUSE="debug doc"
diff --git a/x11-themes/oxygen-gtk/oxygen-gtk-1.0.5.ebuild b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.5.ebuild
new file mode 100644
index 000000000000..30d1e2f44374
--- /dev/null
+++ b/x11-themes/oxygen-gtk/oxygen-gtk-1.0.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk/oxygen-gtk-1.0.5.ebuild,v 1.1 2011/05/20 09:06:46 scarabeus Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+ port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc"
+
+RDEPEND="
+ dev-libs/glib
+ x11-libs/cairo
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(AUTHORS README)
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk
+CONFIG_PROTECT="${EPREFIX}/usr/share/themes/oxygen-gtk/gtk-2.0"
+EOF
+ doenvd 99oxygen-gtk
+}