summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-10-14 23:02:25 +0000
committerAlex Alexander <wired@gentoo.org>2009-10-14 23:02:25 +0000
commit2a67a207e1ab67d87527ccfbabe79f25463de3da (patch)
tree7404ae7628db7b2137ab46ab503cd5a0f9189276 /x11-themes/qtcurve-qt4
parentx11-apps/xinput: bump to 1.5.0, sync with overlay (diff)
downloadgentoo-2-2a67a207e1ab67d87527ccfbabe79f25463de3da.tar.gz
gentoo-2-2a67a207e1ab67d87527ccfbabe79f25463de3da.tar.bz2
gentoo-2-2a67a207e1ab67d87527ccfbabe79f25463de3da.zip
version bump
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/qtcurve-qt4')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog7
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-0.69.1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 7e5e8fc0aef1..f5ec77c922f9 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.79 2009/10/11 21:50:58 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.80 2009/10/14 23:02:25 wired Exp $
+
+*qtcurve-qt4-0.69.1 (14 Oct 2009)
+
+ 14 Oct 2009; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-0.69.1.ebuild:
+ version bump
11 Oct 2009; Jonathan Callen <abcd@gentoo.org> qtcurve-qt4-0.64.2.ebuild,
qtcurve-qt4-0.67.0.ebuild, qtcurve-qt4-0.67.1.ebuild,
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.69.1.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.69.1.ebuild
new file mode 100644
index 000000000000..b176ad0eb2f0
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.69.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.69.1.ebuild,v 1.1 2009/10/14 23:02:25 wired Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+KDE_MINIMAL="4.2"
+inherit flag-o-matic cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for KDE3 and GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ kde? ( >=kde-base/kwin-${KDE_MINIMAL} )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ if use kde ; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}