summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-10 10:52:13 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-10 10:52:13 +0000
commit09bf487ba65f5bc592cf50ee33b12f7b697d885a (patch)
treed16c12ce4a8479de00e0ed5edd0b7a710847176f /x11-themes/qgtkstyle
parentunmasked Qt 4.7.1 (diff)
downloadgentoo-2-09bf487ba65f5bc592cf50ee33b12f7b697d885a.tar.gz
gentoo-2-09bf487ba65f5bc592cf50ee33b12f7b697d885a.tar.bz2
gentoo-2-09bf487ba65f5bc592cf50ee33b12f7b697d885a.zip
new ebuilds for Qt's GTK style
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/qgtkstyle')
-rw-r--r--x11-themes/qgtkstyle/ChangeLog11
-rw-r--r--x11-themes/qgtkstyle/files/qgtkstyle.pro18
-rw-r--r--x11-themes/qgtkstyle/metadata.xml5
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild35
-rw-r--r--x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild35
5 files changed, 104 insertions, 0 deletions
diff --git a/x11-themes/qgtkstyle/ChangeLog b/x11-themes/qgtkstyle/ChangeLog
new file mode 100644
index 000000000000..5bb6119ff31a
--- /dev/null
+++ b/x11-themes/qgtkstyle/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-themes/qgtkstyle
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/ChangeLog,v 1.1 2010/11/10 10:52:13 wired Exp $
+
+*qgtkstyle-4.7.1 (10 Nov 2010)
+*qgtkstyle-4.6.3 (10 Nov 2010)
+
+ 10 Nov 2010; Alex Alexander <wired@gentoo.org> +qgtkstyle-4.6.3.ebuild,
+ +qgtkstyle-4.7.1.ebuild, +files/qgtkstyle.pro, +metadata.xml:
+ new ebuilds for Qt's GTK style
+
diff --git a/x11-themes/qgtkstyle/files/qgtkstyle.pro b/x11-themes/qgtkstyle/files/qgtkstyle.pro
new file mode 100644
index 000000000000..45fa57fdc1ad
--- /dev/null
+++ b/x11-themes/qgtkstyle/files/qgtkstyle.pro
@@ -0,0 +1,18 @@
+TEMPLATE = lib
+CONFIG += qt plugin link_pkgconfig
+
+LIBS += $$QMAKE_LIBS_X11
+PKGCONFIG += gdk-x11-2.0
+PKGCONFIG += atk
+
+contains(QT_CONFIG, reduce_exports):CONFIG += hide_symbols
+
+TARGET = $$qtLibraryTarget(gtkstyle)
+HEADERS = qgtkstyle.h \
+ qgtkpainter_p.h
+SOURCES = qgtkstyle.cpp \
+ qgtkpainter.cpp \
+
+target.path = $$[QT_INSTALL_PLUGINS]/styles
+INSTALLS += target
+
diff --git a/x11-themes/qgtkstyle/metadata.xml b/x11-themes/qgtkstyle/metadata.xml
new file mode 100644
index 000000000000..ab02f994fdd2
--- /dev/null
+++ b/x11-themes/qgtkstyle/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+</pkgmetadata>
diff --git a/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild b/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild
new file mode 100644
index 000000000000..3ba3628ed61f
--- /dev/null
+++ b/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.6.3.ebuild,v 1.1 2010/11/10 10:52:13 wired Exp $
+
+EAPI="3"
+inherit qt4-r2
+
+MY_PV=${PV/_/-}
+MY_P=qt-everywhere-opensource-src-${MY_PV}
+
+DESCRIPTION="Qt style that uses the active GTK theme."
+HOMEPAGE="http://qt.nokia.com/"
+SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ >=x11-libs/qt-gui-${PV}-r1
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/cairo
+"
+RDEPEND="${COMMON_DEPEND}
+ !>x11-libs/qt-gui-${PV}-r9999
+"
+
+src_unpack() {
+ tar xzf "${DISTDIR}"/${MY_P}.tar.gz ${MY_P}/src/gui/styles/ || die
+ mv ${MY_P}/src/gui/styles "${S}" || die
+ cp "${FILESDIR}"/qgtkstyle.pro "${S}"/ || die
+}
diff --git a/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild b/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild
new file mode 100644
index 000000000000..0304d3c2d65e
--- /dev/null
+++ b/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qgtkstyle/qgtkstyle-4.7.1.ebuild,v 1.1 2010/11/10 10:52:13 wired Exp $
+
+EAPI="3"
+inherit qt4-r2
+
+MY_PV=${PV/_/-}
+MY_P=qt-everywhere-opensource-src-${MY_PV}
+
+DESCRIPTION="Qt style that uses the active GTK theme."
+HOMEPAGE="http://qt.nokia.com/"
+SRC_URI="http://get.qt.nokia.com/qt/source/${MY_P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEPEND="
+ x11-libs/gtk+:2
+ >=x11-libs/qt-gui-${PV}-r1
+"
+DEPEND="${COMMON_DEPEND}
+ x11-libs/cairo
+"
+RDEPEND="${COMMON_DEPEND}
+ !>x11-libs/qt-gui-${PV}-r9999
+"
+
+src_unpack() {
+ tar xzf "${DISTDIR}"/${MY_P}.tar.gz ${MY_P}/src/gui/styles/ || die
+ mv ${MY_P}/src/gui/styles "${S}" || die
+ cp "${FILESDIR}"/qgtkstyle.pro "${S}"/ || die
+}