summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-08-02 13:02:56 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-08-02 13:02:56 +0000
commit63dbed5b8b41eefa1e0eb0e3a43d04d278ab2146 (patch)
tree32349501d57f79b8592a8120179d8e28e1fb71eb /x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-63dbed5b8b41eefa1e0eb0e3a43d04d278ab2146.tar.gz
gentoo-2-63dbed5b8b41eefa1e0eb0e3a43d04d278ab2146.tar.bz2
gentoo-2-63dbed5b8b41eefa1e0eb0e3a43d04d278ab2146.zip
Don't inherit from gtk-engines.eclass
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild')
-rw-r--r--x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild b/x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..4c54f02c7045
--- /dev/null
+++ b/x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-thinice/gtk-engines-thinice-1.0.4-r1.ebuild,v 1.1 2005/08/02 13:02:56 leonardop Exp $
+
+MY_P="gtk-thinice-theme-${PV}"
+DESCRIPTION="Thinice theme engine for GTK+ 1"
+SRC_URI="mirror://sourceforge/thinice/${MY_P}.tar.gz"
+HOMEPAGE="http://thinice.sourceforge.net/"
+
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64"
+SLOT="1"
+LICENSE="GPL-2"
+IUSE="static"
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf="$(use_enable static)"
+
+ econf $myconf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog README TODO
+}