summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-15 13:07:26 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-15 13:07:26 +0000
commitbdb133f9e2043f39ea213d6d2ccb31969d093303 (patch)
tree6e41b86d86e84331ea196e41e66b85779f64fffc /x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
parentVersion bump (#217015), remove useless virtual/libc depend, remove static use... (diff)
downloadgentoo-2-bdb133f9e2043f39ea213d6d2ccb31969d093303.tar.gz
gentoo-2-bdb133f9e2043f39ea213d6d2ccb31969d093303.tar.bz2
gentoo-2-bdb133f9e2043f39ea213d6d2ccb31969d093303.zip
use autotools eclass instead of calling autoconf directly, bug #226643. Fix various QA warnings.
(Portage version: 2.1.5.4)
Diffstat (limited to 'x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild')
-rw-r--r--x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild b/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
index 923976161364..4e0738b261ea 100644
--- a/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
+++ b/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
@@ -1,17 +1,19 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild,v 1.7 2007/07/11 02:54:47 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild,v 1.8 2008/06/15 13:07:26 eva Exp $
-inherit eutils
+inherit autotools eutils
MY_P="QtPixmap-${PV}"
DESCRIPTION="A modified version of the original GTK pixmap engine which follows the KDE color scheme"
HOMEPAGE="http://www.kde-look.org/content/show.php?content=7043"
SRC_URI="http://www.cpdrummond.freeuk.com/${MY_P}.tar.gz"
+
KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
LICENSE="GPL-2"
SLOT="0"
+
IUSE=""
RDEPEND=">=x11-libs/gtk+-2"
@@ -21,14 +23,14 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
# Add switches to enable/disable gtk1 and gtk2 engines in the configure
# script.
- epatch ${FILESDIR}/${P}-gtk_switches.patch
+ epatch "${FILESDIR}/${P}-gtk_switches.patch"
- autoconf || die "autoconf failed"
+ eautoreconf
}
src_compile() {
@@ -39,7 +41,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${D}" install || die "Installation failed"
dodoc AUTHORS ChangeLog README
}