summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-17 13:23:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-17 13:23:45 +0000
commit82eefdc306721730f5fd0c69d2bc270627a4229a (patch)
treeee42a31f6c179cfe246038360c854fe134f58034 /x11-themes/baghira
parentStable on hppa (bug #125810). (diff)
downloadgentoo-2-82eefdc306721730f5fd0c69d2bc270627a4229a.tar.gz
gentoo-2-82eefdc306721730f5fd0c69d2bc270627a4229a.tar.bz2
gentoo-2-82eefdc306721730f5fd0c69d2bc270627a4229a.zip
Add patch to build with GCC 4.1, provided by Matteo Azzali in bug #126513.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'x11-themes/baghira')
-rw-r--r--x11-themes/baghira/ChangeLog8
-rw-r--r--x11-themes/baghira/baghira-0.7.ebuild6
-rw-r--r--x11-themes/baghira/files/baghira-0.7-gcc41.patch13
3 files changed, 23 insertions, 4 deletions
diff --git a/x11-themes/baghira/ChangeLog b/x11-themes/baghira/ChangeLog
index d43db6af35f4..4b0304d1ad53 100644
--- a/x11-themes/baghira/ChangeLog
+++ b/x11-themes/baghira/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-themes/baghira
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/baghira/ChangeLog,v 1.43 2005/11/26 14:47:50 metalgod Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/baghira/ChangeLog,v 1.44 2006/03/17 13:23:45 flameeyes Exp $
+
+ 17 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/baghira-0.7-gcc41.patch, baghira-0.7.ebuild:
+ Add patch to build with GCC 4.1, provided by Matteo Azzali in bug #126513.
26 Nov 2005; Luis Medinas <metalgod@gentoo.org> baghira-0.6e-r1.ebuild:
Stable on amd64.
diff --git a/x11-themes/baghira/baghira-0.7.ebuild b/x11-themes/baghira/baghira-0.7.ebuild
index a896b8c17ba5..075accc4c8a0 100644
--- a/x11-themes/baghira/baghira-0.7.ebuild
+++ b/x11-themes/baghira/baghira-0.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/baghira/baghira-0.7.ebuild,v 1.2 2005/10/04 12:37:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/baghira/baghira-0.7.ebuild,v 1.3 2006/03/17 13:23:45 flameeyes Exp $
inherit kde
@@ -19,3 +19,5 @@ DEPEND="|| ( kde-base/kwin >=kde-base/kdebase-3.3 )
need-kde 3.3
S="${WORKDIR}/${PN}-release"
+
+PATCHES="${FILESDIR}/${P}-gcc41.patch"
diff --git a/x11-themes/baghira/files/baghira-0.7-gcc41.patch b/x11-themes/baghira/files/baghira-0.7-gcc41.patch
new file mode 100644
index 000000000000..96a97d8b1d00
--- /dev/null
+++ b/x11-themes/baghira/files/baghira-0.7-gcc41.patch
@@ -0,0 +1,13 @@
+--- deco/baghiraclient.h.orig 2006-03-17 12:49:33.000000000 +0100
++++ deco/baghiraclient.h 2006-03-17 12:52:47.000000000 +0100
+@@ -159,8 +159,8 @@
+ virtual KDecoration *createDecoration(KDecorationBridge *b);
+ virtual bool reset(unsigned long changed);
+ virtual QValueList<BorderSize> borderSizes() const;
+- static QPixmap &BaghiraFactory::ButtonPixmap(Baghira::WindowState wState, Baghira::ButtonType type, Baghira::ButtonState state, int current, bool small);
+- QImage* BaghiraFactory::DecoImage(QPixmap *pix, int x, int y, int width, int height);
++ static QPixmap &ButtonPixmap(Baghira::WindowState wState, Baghira::ButtonType type, Baghira::ButtonState state, int current, bool small);
++ QImage* DecoImage(QPixmap *pix, int x, int y, int width, int height);
+
+ static QBitmap helpMask, jaguarDownMask, jaguarMenuDownMask,
+ jaguarMenuMask, jaguarMask, milkMenuDownMask,