summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2006-02-16 19:13:08 +0000
committerAlastair Tse <liquidx@gentoo.org>2006-02-16 19:13:08 +0000
commite5a018f7113bfb7f3d25a894c2438d4ba89f9398 (patch)
tree4a0698e893567b7f929268c2f76f75ef0d94f331 /x11-terms/kterm/kterm-6.2.0-r4.ebuild
parentfix ChangeLog header (diff)
downloadgentoo-2-e5a018f7113bfb7f3d25a894c2438d4ba89f9398.tar.gz
gentoo-2-e5a018f7113bfb7f3d25a894c2438d4ba89f9398.tar.bz2
gentoo-2-e5a018f7113bfb7f3d25a894c2438d4ba89f9398.zip
added more support for escape characters. thanks to OKUMURA N, Shin-ya (#104028)
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-terms/kterm/kterm-6.2.0-r4.ebuild')
-rw-r--r--x11-terms/kterm/kterm-6.2.0-r4.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/x11-terms/kterm/kterm-6.2.0-r4.ebuild b/x11-terms/kterm/kterm-6.2.0-r4.ebuild
new file mode 100644
index 000000000000..7c16642140dd
--- /dev/null
+++ b/x11-terms/kterm/kterm-6.2.0-r4.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/kterm/kterm-6.2.0-r4.ebuild,v 1.1 2006/02/16 19:13:08 liquidx Exp $
+
+inherit eutils flag-o-matic
+
+IUSE="Xaw3d"
+
+DESCRIPTION="Japanese Kanji X Terminal"
+SRC_URI="ftp://ftp.x.org/contrib/applications/${P}.tar.gz
+ http://www.asahi-net.or.jp/~hc3j-tkg/kterm/${P}-wpi.patch.gz
+ http://www.st.rim.or.jp/~hanataka/${P}.ext02.patch.gz"
+# until someone who reads japanese can find a better place
+HOMEPAGE="http://www.asahi-net.or.jp/~hc3j-tkg/kterm/"
+LICENSE="X11"
+SLOT="0"
+KEYWORDS="-alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="app-text/rman
+ sys-libs/ncurses
+ || ( ( x11-libs/libXmu x11-libs/libXpm x11-libs/libxkbfile )
+ virtual/x11 )
+ Xaw3d? ( x11-libs/Xaw3d )"
+
+src_unpack(){
+ unpack ${A}
+
+ cd ${S}
+ epatch ${WORKDIR}/${P}-wpi.patch # wallpaper patch
+ epatch ${WORKDIR}/${P}.ext02.patch # JIS 0213 support
+ epatch ${FILESDIR}/${P}-openpty.patch
+ epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${PN}-ad-gentoo.diff
+ epatch ${FILESDIR}/${PV}-underline.patch
+
+ if use Xaw3d ; then
+ epatch ${FILESDIR}/kterm-6.2.0-Xaw3d.patch
+ fi
+}
+
+src_compile(){
+ xmkmf -a || die
+ emake EXTRA_LDOPTIONS="$(bindnow-flags)" || die
+}
+
+src_install(){
+
+ einstall DESTDIR=${D} BINDIR=/usr/bin || die
+
+ # install man pages
+ newman kterm.man kterm.1
+ insinto /usr/share/man/ja/man1
+ iconv -f ISO-2022-JP -t EUC-JP kterm.jman > kterm.ja.1
+ newins kterm.ja.1 kterm.1
+
+ dodoc README.kt
+}
+
+pkg_postinst() {
+ einfo
+ einfo "KTerm wallpaper support is enabled."
+ einfo "In order to use this feature,"
+ einfo "you need specify favourite xpm file with -wp option"
+ einfo
+ einfo "\t% kterm -wp filename.xpm"
+ einfo
+ einfo "or set it with X resource"
+ einfo
+ einfo "\tKTerm*wallPaper: /path/to/filename.xpm"
+ einfo
+}