summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-01-11 01:24:45 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-01-11 01:24:45 +0000
commit8d913b9a47f097c17dd333f724ecdfb99357faf2 (patch)
tree9244b0a706310c4149dca35e5ac003949fc869d0 /x11-terms/clusterssh
parentRemove older version. (diff)
downloadgentoo-2-8d913b9a47f097c17dd333f724ecdfb99357faf2.tar.gz
gentoo-2-8d913b9a47f097c17dd333f724ecdfb99357faf2.tar.bz2
gentoo-2-8d913b9a47f097c17dd333f724ecdfb99357faf2.zip
Version bump (Bug 180892). Add small patches from by tmancill@debian.org.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-terms/clusterssh')
-rw-r--r--x11-terms/clusterssh/ChangeLog11
-rw-r--r--x11-terms/clusterssh/clusterssh-3.21.ebuild46
-rw-r--r--x11-terms/clusterssh/files/clusterssh-3.21-disable-warning.patch14
-rw-r--r--x11-terms/clusterssh/files/clusterssh-3.21-xrm-remove-class.patch23
-rw-r--r--x11-terms/clusterssh/files/digest-clusterssh-3.213
5 files changed, 95 insertions, 2 deletions
diff --git a/x11-terms/clusterssh/ChangeLog b/x11-terms/clusterssh/ChangeLog
index 6cd6b1391272..3f1cd0133183 100644
--- a/x11-terms/clusterssh/ChangeLog
+++ b/x11-terms/clusterssh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-terms/clusterssh
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/clusterssh/ChangeLog,v 1.19 2007/07/29 16:59:54 dertobi123 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/clusterssh/ChangeLog,v 1.20 2008/01/11 01:24:44 jsbronder Exp $
+
+*clusterssh-3.21 (11 Jan 2008)
+
+ 11 Jan 2008; Justin Bronder <jsbronder@gentoo.org>
+ +files/clusterssh-3.21-disable-warning.patch,
+ +files/clusterssh-3.21-xrm-remove-class.patch, +clusterssh-3.21.ebuild:
+ Version bump (Bug 180892). Add small patches from by tmancill@debian.org.
29 Jul 2007; Tobias Scherbaum <dertobi123@gentoo.org>
clusterssh-3.18.1-r1.ebuild:
diff --git a/x11-terms/clusterssh/clusterssh-3.21.ebuild b/x11-terms/clusterssh/clusterssh-3.21.ebuild
new file mode 100644
index 000000000000..ed5ecd965835
--- /dev/null
+++ b/x11-terms/clusterssh/clusterssh-3.21.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/clusterssh/clusterssh-3.21.ebuild,v 1.1 2008/01/11 01:24:44 jsbronder Exp $
+
+inherit eutils
+
+DESCRIPTION="Concurrent Multi-Server Terminal Access."
+HOMEPAGE="http://clusterssh.sourceforge.net"
+SRC_URI="mirror://sourceforge/clusterssh/clusterssh-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.1
+ dev-perl/perl-tk
+ dev-perl/Config-Simple
+ dev-perl/X11-Protocol
+ x11-apps/xlsfonts"
+
+src_unpack() {
+ unpack "${A}"
+ epatch "${FILESDIR}"/${PN}-3.21-disable-warning.patch
+ epatch "${FILESDIR}"/${PN}-3.21-xrm-remove-class.patch
+}
+
+src_compile() {
+ # Gentoo perl ebuilds remove podchecker
+ if grep -v podchecker "${S}"/src/Makefile.in \
+ > "${S}"/src/Makefile.in.new; then
+ mv "${S}"/src/Makefile.in.new "${S}"/src/Makefile.in
+ else
+ die "Makefile.in update failed"
+ fi
+
+ econf || die "configuration failed"
+ emake || die "compiling failed"
+}
+
+src_install() {
+ cd "${S}"
+ dodoc AUTHORS COPYING INSTALL NEWS README THANKS
+ dobin src/cssh
+ doman src/cssh.1
+}
diff --git a/x11-terms/clusterssh/files/clusterssh-3.21-disable-warning.patch b/x11-terms/clusterssh/files/clusterssh-3.21-disable-warning.patch
new file mode 100644
index 000000000000..d0f81ebcfe13
--- /dev/null
+++ b/x11-terms/clusterssh/files/clusterssh-3.21-disable-warning.patch
@@ -0,0 +1,14 @@
+## 05_font_override.dpatch by <tmancill@debian.org>
+
+diff -urN clusterssh-3.21/src/cssh.pl clusterssh-3.21-patched/src/cssh.pl
+--- clusterssh-3.21/src/cssh.pl 2007-11-28 17:11:14.000000000 -0500
++++ clusterssh-3.21-patched/src/cssh.pl 2008-01-10 19:33:15.000000000 -0500
+@@ -603,7 +603,7 @@
+ sub update_display_text($) {
+ my $char = shift;
+
+-warn("config{show_history}=$config{show_history}");
++#warn("config{show_history}=$config{show_history}");
+
+ return if(!$config{show_history});
+
diff --git a/x11-terms/clusterssh/files/clusterssh-3.21-xrm-remove-class.patch b/x11-terms/clusterssh/files/clusterssh-3.21-xrm-remove-class.patch
new file mode 100644
index 000000000000..71e473360503
--- /dev/null
+++ b/x11-terms/clusterssh/files/clusterssh-3.21-xrm-remove-class.patch
@@ -0,0 +1,23 @@
+## 02_uxterm.dpatch by <tmancill@debian.org>
+
+diff -urN clusterssh-3.21/src/cssh.pl clusterssh-3.21-patched/src/cssh.pl
+--- clusterssh-3.21/src/cssh.pl 2008-01-10 19:35:35.000000000 -0500
++++ clusterssh-3.21-patched/src/cssh.pl 2008-01-10 19:37:35.000000000 -0500
+@@ -162,7 +162,7 @@
+ $config{terminal_args} = "";
+ $config{terminal_title_opt} = "-T";
+ $config{terminal_allow_send_events} =
+- "-xrm 'XTerm.VT100.allowSendEvents:true'";
++ "-xrm '*.VT100.allowSendEvents:true'";
+ $config{terminal_font} = "6x13";
+ $config{terminal_size} = "80x24";
+ $config{use_hotkeys} = "yes";
+@@ -2196,7 +2196,7 @@
+
+ Option used with C<terminal> to set the title of the window
+
+-=item terminal_allow_send_events = -xrm 'XTerm.VT100.allowSendEvents:true'
++=item terminal_allow_send_events = -xrm '*.VT100.allowSendEvents:true'
+
+ Option required by the terminal to allow XSendEvents to be received
+
diff --git a/x11-terms/clusterssh/files/digest-clusterssh-3.21 b/x11-terms/clusterssh/files/digest-clusterssh-3.21
new file mode 100644
index 000000000000..8d163a2c6e3e
--- /dev/null
+++ b/x11-terms/clusterssh/files/digest-clusterssh-3.21
@@ -0,0 +1,3 @@
+MD5 818ae23f9145c185a3f24301e8981981 clusterssh-3.21.tar.gz 90744
+RMD160 fe8cd575c5154f3c95dbd2e0e35eb6959b1d8068 clusterssh-3.21.tar.gz 90744
+SHA256 17746ed7a3e8854737a117e3f7b4ecc7c104ab1461f96da2828eb31702470288 clusterssh-3.21.tar.gz 90744