summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-10-14 07:17:19 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-10-14 07:17:19 +0000
commit3b13c68e08928bfaa598a1bb643e57b5928a303f (patch)
treef1ccef49a26a3d6fe0c777fed1868dcb29bbe71a /x11-proto/glproto
parentThis workaround is no longer needed as of about a year ago, so killing it off. (diff)
downloadgentoo-2-3b13c68e08928bfaa598a1bb643e57b5928a303f.tar.gz
gentoo-2-3b13c68e08928bfaa598a1bb643e57b5928a303f.tar.bz2
gentoo-2-3b13c68e08928bfaa598a1bb643e57b5928a303f.zip
Bump for new xorg-server snapshot.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'x11-proto/glproto')
-rw-r--r--x11-proto/glproto/ChangeLog8
-rw-r--r--x11-proto/glproto/files/digest-glproto-1.4.1_pre200510131
-rw-r--r--x11-proto/glproto/glproto-1.4.1_pre20051013.ebuild52
3 files changed, 60 insertions, 1 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index f69f0250589d..bd2a3712563f 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.12 2005/09/09 17:32:23 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.13 2005/10/14 07:17:19 spyderous Exp $
+
+*glproto-1.4.1_pre20051013 (14 Oct 2005)
+
+ 14 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +glproto-1.4.1_pre20051013.ebuild:
+ Bump for new xorg-server snapshot.
09 Sep 2005; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml:
Add metadata.
diff --git a/x11-proto/glproto/files/digest-glproto-1.4.1_pre20051013 b/x11-proto/glproto/files/digest-glproto-1.4.1_pre20051013
new file mode 100644
index 000000000000..0e9e8b8bdacf
--- /dev/null
+++ b/x11-proto/glproto/files/digest-glproto-1.4.1_pre20051013
@@ -0,0 +1 @@
+MD5 ebf5a9192f01e811444fe4aaf9431e15 glproto-1.4.1_pre20051013.tar.bz2 53014
diff --git a/x11-proto/glproto/glproto-1.4.1_pre20051013.ebuild b/x11-proto/glproto/glproto-1.4.1_pre20051013.ebuild
new file mode 100644
index 000000000000..5ac97fcff620
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.1_pre20051013.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.1_pre20051013.ebuild,v 1.1 2005/10/14 07:17:19 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+#HOMEPAGE="http://foo.bar.com/"
+SRC_URI="http://dev.gentoo.org/~spyderous/xorg-x11/${P}.tar.bz2"
+#LICENSE=""
+#SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sh ~sparc ~x86"
+#IUSE="X gnome"
+DEPEND="app-admin/eselect-opengl"
+#RDEPEND=""
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}