summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-01-25 15:44:55 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-01-25 15:44:55 +0000
commitfafaa7757a2c3a2bdd69ae21a6dac06f174cab38 (patch)
treea3bf9d45d7b88ca18a24dab482f1d42a677fc62c /x11-plugins
parentStable on alpha, bug #254307 (diff)
downloadgentoo-2-fafaa7757a2c3a2bdd69ae21a6dac06f174cab38.tar.gz
gentoo-2-fafaa7757a2c3a2bdd69ae21a6dac06f174cab38.tar.bz2
gentoo-2-fafaa7757a2c3a2bdd69ae21a6dac06f174cab38.zip
Bump, new home. Fixes bug 225319.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/tomboy-reminder/ChangeLog11
-rw-r--r--x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch27
-rw-r--r--x11-plugins/tomboy-reminder/tomboy-reminder-0.9.1.ebuild30
-rw-r--r--x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild33
4 files changed, 39 insertions, 62 deletions
diff --git a/x11-plugins/tomboy-reminder/ChangeLog b/x11-plugins/tomboy-reminder/ChangeLog
index cb2b0ff0f05f..b3689601da29 100644
--- a/x11-plugins/tomboy-reminder/ChangeLog
+++ b/x11-plugins/tomboy-reminder/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/tomboy-reminder
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/ChangeLog,v 1.6 2008/12/10 15:52:12 loki_val Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/ChangeLog,v 1.7 2009/01/25 15:44:55 loki_val Exp $
+
+*tomboy-reminder-0.9.1 (25 Jan 2009)
+
+ 25 Jan 2009; Peter Alfredsen <loki_val@gentoo.org>
+ -files/tomboy-reminder-0.9-mcs-to-gmcs.patch, -tomboy-reminder-0.9.ebuild,
+ +tomboy-reminder-0.9.1.ebuild:
+ Bump, new home. Fixes bug 225319.
10 Dec 2008; Peter Alfredsen <loki_val@gentoo.org> metadata.xml,
tomboy-reminder-0.9.ebuild:
diff --git a/x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch b/x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch
deleted file mode 100644
index 0040bff88ac5..000000000000
--- a/x11-plugins/tomboy-reminder/files/tomboy-reminder-0.9-mcs-to-gmcs.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/Makefile.am 2006-12-21 09:50:16.000000000 -0600
-+++ src/Makefile.am 2006-12-21 09:50:21.000000000 -0600
-@@ -1,5 +1,5 @@
-
--CSC = mcs -debug
-+CSC = gmcs -debug
-
- TARGET_NAME = tomboy-reminder
- TARGET = $(TARGET_NAME).dll
---- configure.in 2006-12-21 09:50:32.000000000 -0600
-+++ configure.in 2006-12-21 09:51:22.000000000 -0600
-@@ -5,11 +5,11 @@
- AC_PROG_INSTALL
-
- #
--# Find mcs
-+# Find gmcs
- #
--AC_PATH_PROG(MCS, mcs)
--if test "x$MCS" = "x" ; then
-- AC_MSG_ERROR([Can't find "mcs", the mono compiler in your PATH])
-+AC_PATH_PROG(GMCS, gmcs)
-+if test "x$GMCS" = "x" ; then
-+ AC_MSG_ERROR([Can't find "gmcs", the mono compiler in your PATH])
- fi
-
- #
diff --git a/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.1.ebuild b/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.1.ebuild
new file mode 100644
index 000000000000..45c82ca3def2
--- /dev/null
+++ b/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.1.ebuild,v 1.1 2009/01/25 15:44:55 loki_val Exp $
+
+EAPI=2
+
+inherit base autotools mono
+
+DESCRIPTION="Reminder Plugin for Tomboy"
+HOMEPAGE="http://flukkost.nu/blog/tomboy-reminder/"
+SRC_URI="http://flukkost.nu/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0
+ >=app-misc/tomboy-0.12"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9-unicode-regex.patch"
+)
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README NEWS ChangeLog AUTHORS || die "dodoc failed"
+}
diff --git a/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild b/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild
deleted file mode 100644
index ca5cf5afa28b..000000000000
--- a/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/tomboy-reminder/tomboy-reminder-0.9.ebuild,v 1.6 2008/12/10 15:52:12 loki_val Exp $
-
-inherit autotools eutils mono
-
-DESCRIPTION="Reminder Plugin for Tomboy"
-HOMEPAGE="http://raphael.slinckx.net/blog/projects/tomboy-reminder-plugin/"
-SRC_URI="http://raphael.slinckx.net/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=dev-lang/mono-1.0
- >=app-misc/tomboy-0.5.2"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.19"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-0.9-mcs-to-gmcs.patch
- epatch "${FILESDIR}"/${PN}-0.9-unicode-regex.patch
- eautomake
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc README NEWS ChangeLog AUTHORS
-}