summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-27 15:10:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-27 15:10:09 +0000
commitee06226816fa4e78de37dee4ad49af1cc297bc7d (patch)
tree665c68958be03897404f1b8437b0eed1c68a38f3 /x11-plugins
parentVersion bump. Drop old. (diff)
downloadgentoo-2-ee06226816fa4e78de37dee4ad49af1cc297bc7d.tar.gz
gentoo-2-ee06226816fa4e78de37dee4ad49af1cc297bc7d.tar.bz2
gentoo-2-ee06226816fa4e78de37dee4ad49af1cc297bc7d.zip
version bump
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog8
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p41.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
index f3304f097efb..09f38bad8091 100644
--- a/x11-plugins/pidgin-opensteamworks/ChangeLog
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/pidgin-opensteamworks
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.12 2013/01/29 19:34:57 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.13 2013/04/27 15:10:09 hasufell Exp $
+
+*pidgin-opensteamworks-1.0_p41 (27 Apr 2013)
+
+ 27 Apr 2013; Julian Ospald <hasufell@gentoo.org>
+ +pidgin-opensteamworks-1.0_p41.ebuild:
+ version bump
*pidgin-opensteamworks-1.0_p38 (29 Jan 2013)
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p41.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p41.ebuild
new file mode 100644
index 000000000000..5fac1bb66b0e
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p41.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p41.ebuild,v 1.1 2013/04/27 15:10:09 hasufell Exp $
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Steam protocol plugin for pidgin"
+HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
+SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+ http://pidgin-opensteamworks.googlecode.com/files/icons.zip
+ -> ${PN}-icons.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/json-glib
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ # see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
+ cp "${FILESDIR}"/${PN}-1.0_p32-Makefile "${S}"/Makefile || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/pixmaps/pidgin/protocols
+ doins -r "${WORKDIR}"/{16,48}
+}