summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-07-30 11:12:09 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-07-30 11:12:09 +0000
commitcc91cc24bcbccb1df3552f05e3494e9c8405d158 (patch)
treee6ba188d059f788ee4d962133e3b1c2ba626c0d3 /x11-plugins
parentVersion bump, bug #141033. Reported by Shark <shark@bitchx.it>. (diff)
downloadgentoo-2-cc91cc24bcbccb1df3552f05e3494e9c8405d158.tar.gz
gentoo-2-cc91cc24bcbccb1df3552f05e3494e9c8405d158.tar.bz2
gentoo-2-cc91cc24bcbccb1df3552f05e3494e9c8405d158.zip
Bump patches to match thunderbird-1.5.0.5. Patch provided by Joshua Baergen <joshuabaergen@gentoo.org>.
(Portage version: 2.1.1_pre4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/ChangeLog9
-rw-r--r--x11-plugins/enigmail/enigmail-0.94.0-r5.ebuild137
-rw-r--r--x11-plugins/enigmail/files/digest-enigmail-0.94.0-r59
3 files changed, 154 insertions, 1 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
index b95c64bfadc4..6aa42c742695 100644
--- a/x11-plugins/enigmail/ChangeLog
+++ b/x11-plugins/enigmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/enigmail
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.26 2006/07/26 05:03:57 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.27 2006/07/30 11:12:09 kloeri Exp $
+
+*enigmail-0.94.0-r5 (30 Jul 2006)
+
+ 30 Jul 2006; Bryan Østergaard <kloeri@gentoo.org>
+ +enigmail-0.94.0-r5.ebuild:
+ Bump patches to match thunderbird-1.5.0.5. Patch provided by Joshua Baergen
+ <joshuabaergen@gentoo.org>.
26 Jul 2006; Joshua Kinard <kumba@gentoo.org> enigmail-0.94.0-r4.ebuild:
Modified ebuild to use the 0.2 patchball from thunderbird, uses *.patch
diff --git a/x11-plugins/enigmail/enigmail-0.94.0-r5.ebuild b/x11-plugins/enigmail/enigmail-0.94.0-r5.ebuild
new file mode 100644
index 000000000000..c5f4296d5c4e
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-0.94.0-r5.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.0-r5.ebuild,v 1.1 2006/07/30 11:12:09 kloeri Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib autotools
+
+EMVER=${PV}
+TBVER="1.5.0.5"
+TBPVER="0.1"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ mirror://gentoo/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz"
+
+KEYWORDS="~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND=">=mail-client/mozilla-thunderbird-${TBVER}"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack thunderbird-${TBVER}-source.tar.bz2 mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2 || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch ${WORKDIR}/patch
+
+ # Unpack the enigmail plugin
+ cd ${S}/mailnews/extensions || die
+ unpack enigmail-${EMVER}.tar.gz
+ cd ${S}/mailnews/extensions/enigmail || die "cd failed"
+ makemake2
+
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' mailnews/extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade-1.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-system-nspr \
+ --with-system-nss \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C ${S}/mailnews/extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C ${S}/mailnews/extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+}
diff --git a/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r5 b/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r5
new file mode 100644
index 000000000000..a1df7b944260
--- /dev/null
+++ b/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r5
@@ -0,0 +1,9 @@
+MD5 d326c302c1d2d68217fffcaa01ca7632 enigmail-0.94.0.tar.gz 508113
+RMD160 0fa8f0384b74623c1b84a048bdbf04bfca8c1824 enigmail-0.94.0.tar.gz 508113
+SHA256 db2b5fc014fe5efef95fc46804ac609616557b1696d5f355d2d7641e567904f3 enigmail-0.94.0.tar.gz 508113
+MD5 1a7192b65d270b4249558a1f32f191bf mozilla-thunderbird-1.5.0.5-patches-0.1.tar.bz2 30684
+RMD160 82a4da8cf5dad04c1bedc9425d31f33a8eedf31f mozilla-thunderbird-1.5.0.5-patches-0.1.tar.bz2 30684
+SHA256 6f707b64a4e1ca1b36287f45f018cb70b6e04d7e0580cba7805b403ae1092f93 mozilla-thunderbird-1.5.0.5-patches-0.1.tar.bz2 30684
+MD5 b09d29f912c2133a75b44f4801fc62b0 thunderbird-1.5.0.5-source.tar.bz2 35998778
+RMD160 aa32d59efa7d55eb516d967c1fb4cc6cc13f874b thunderbird-1.5.0.5-source.tar.bz2 35998778
+SHA256 b6fc27b79d0a4dabb30011cc6ba6161080f991ccadae12e5214cac86d009b005 thunderbird-1.5.0.5-source.tar.bz2 35998778