summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-08-13 13:58:16 +0000
committerDon Seiler <rizzo@gentoo.org>2004-08-13 13:58:16 +0000
commit92e2e9aadb9efdf72cb30a8870a3a23cd3254937 (patch)
tree5f4db792bb05cfce11900aa3c7d4924bad0fafd2 /x11-plugins
parentstable on x86 (Manifest recommit) (diff)
downloadgentoo-2-92e2e9aadb9efdf72cb30a8870a3a23cd3254937.tar.gz
gentoo-2-92e2e9aadb9efdf72cb30a8870a3a23cd3254937.tar.bz2
gentoo-2-92e2e9aadb9efdf72cb30a8870a3a23cd3254937.zip
Version bump
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gaim-encryption/ChangeLog7
-rw-r--r--x11-plugins/gaim-encryption/Manifest2
-rw-r--r--x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.291
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.29.ebuild41
4 files changed, 50 insertions, 1 deletions
diff --git a/x11-plugins/gaim-encryption/ChangeLog b/x11-plugins/gaim-encryption/ChangeLog
index 89950a4889a1..edfcccbc11e4 100644
--- a/x11-plugins/gaim-encryption/ChangeLog
+++ b/x11-plugins/gaim-encryption/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/gaim-encryption
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.11 2004/08/02 17:50:23 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/ChangeLog,v 1.12 2004/08/13 13:58:16 rizzo Exp $
+
+*gaim-encryption-2.29 (13 Aug 2004)
+
+ 13 Aug 2004; Don Seiler <rizzo@gentoo.org> +gaim-encryption-2.29.ebuild:
+ Version bump
02 Aug 2004; Gustavo Zacarias <gustavoz@gentoo.org>
gaim-encryption-2.28.ebuild:
diff --git a/x11-plugins/gaim-encryption/Manifest b/x11-plugins/gaim-encryption/Manifest
index c82d29b5a6b9..a4e127874d28 100644
--- a/x11-plugins/gaim-encryption/Manifest
+++ b/x11-plugins/gaim-encryption/Manifest
@@ -1,4 +1,6 @@
+MD5 8be77bae276f477f471105ff4b1ea07b gaim-encryption-2.29.ebuild 1130
MD5 ab7db4bf9ff48c8de9da14fd12f6c15c metadata.xml 344
MD5 f5fcabd688079e7907d5484ed6017cfe ChangeLog 5704
MD5 1832e11222ef97ebb2bf22fff463f024 gaim-encryption-2.28.ebuild 1122
+MD5 571e96ba73294761bf61482053d3f169 files/digest-gaim-encryption-2.29 72
MD5 4199a4a07c312219c1667706cd77df4f files/digest-gaim-encryption-2.28 72
diff --git a/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.29 b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.29
new file mode 100644
index 000000000000..5aebcdc1cb4d
--- /dev/null
+++ b/x11-plugins/gaim-encryption/files/digest-gaim-encryption-2.29
@@ -0,0 +1 @@
+MD5 f708435e21aff930bf17a4b4d94f5c98 gaim-encryption-2.29.tar.gz 484602
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.29.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.29.ebuild
new file mode 100644
index 000000000000..5028ee089444
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.29.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.29.ebuild,v 1.1 2004/08/13 13:58:16 rizzo Exp $
+
+inherit flag-o-matic eutils
+use debug && inherit debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~alpha ~ia64 ~hppa ~mips"
+IUSE="debug"
+
+DEPEND=">=net-im/gaim-0.80
+ dev-libs/nss"
+
+src_compile() {
+ local myconf
+
+ NSS_LIB=/usr/lib
+ NSS_INC=/usr/include
+ myconf="${myconf} --with-nspr-includes=${NSS_INC}/nspr"
+ myconf="${myconf} --with-nss-includes=${NSS_INC}/nss"
+ myconf="${myconf} --with-nspr-libs=${NSS_LIB}"
+ myconf="${myconf} --with-nss-libs=${NSS_LIB}"
+
+ econf ${myconf} || die "Configuration failed"
+ einfo "Replacing -Os CFLAG with -O2"
+ replace-flags -Os -O2
+
+ emake || emake -j1 || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc CHANGELOG COPYING INSTALL NOTES README TODO VERSION WISHLIST
+}
+