summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-07-06 09:54:28 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-07-06 09:54:28 +0000
commit5cf1dfea967cb4b5fe34120f24cc3a386a079ce3 (patch)
treeaf464228088e3373d7f1d65aba2dea3b8fbf6a16 /x11-plugins
parentadjust kmm_kbanking for aqbanking 4 (diff)
downloadgentoo-2-5cf1dfea967cb4b5fe34120f24cc3a386a079ce3.tar.gz
gentoo-2-5cf1dfea967cb4b5fe34120f24cc3a386a079ce3.tar.bz2
gentoo-2-5cf1dfea967cb4b5fe34120f24cc3a386a079ce3.zip
Version bump, adds option to disable history, shows users away and idle, fix buddy names not being shown straight away, and other bugfixes
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-facebookchat/ChangeLog9
-rw-r--r--x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.54.ebuild41
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-plugins/pidgin-facebookchat/ChangeLog b/x11-plugins/pidgin-facebookchat/ChangeLog
index 73174dea74cb..77a97d78543f 100644
--- a/x11-plugins/pidgin-facebookchat/ChangeLog
+++ b/x11-plugins/pidgin-facebookchat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/pidgin-facebookchat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.21 2009/06/29 09:22:05 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/ChangeLog,v 1.22 2009/07/06 09:54:28 voyageur Exp $
+
+*pidgin-facebookchat-1.54 (06 Jul 2009)
+
+ 06 Jul 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-facebookchat-1.54.ebuild:
+ Version bump, adds option to disable history, shows users away and idle,
+ fix buddy names not being shown straight away, and other bugfixes
*pidgin-facebookchat-1.53 (29 Jun 2009)
diff --git a/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.54.ebuild b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.54.ebuild
new file mode 100644
index 000000000000..bf0cd32d2c96
--- /dev/null
+++ b/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.54.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-facebookchat/pidgin-facebookchat-1.54.ebuild,v 1.1 2009/07/06 09:54:28 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Facebook chat plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/pidgin-facebookchat/"
+
+SRC_URI="http://pidgin-facebookchat.googlecode.com/files/${PN}-source-${PV}.tar.bz2"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/json-glib
+ >=net-im/pidgin-2.3.0"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # Grabbed from makefile
+ FACEBOOK_SOURCES="libfacebook.c fb_blist.c fb_connection.c fb_conversation.c fb_info.c fb_managefriends.c fb_messages.c fb_notifications.c fb_search.c fb_util.c"
+ $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} `pkg-config --cflags purple json-glib-1.0` \
+ -DPURPLE_PLUGINS -DENABLE_NLS -DHAVE_ZLIB -shared -fPIC -DPIC \
+ ${FACEBOOK_SOURCES} `pkg-config --libs json-glib-1.0` \
+ -o libfacebook.so || die "compilation failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/purple-2
+ doexe libfacebook.so
+ for size in 16 22 48; do
+ insinto /usr/share/pixmaps/pidgin/protocols/${size}
+ newins facebook${size}.png facebook.png
+ done
+}