summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-04 18:47:36 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-04 18:47:36 +0000
commitd2ceeb20b81c0c78dff73e829fbd50db694f0c25 (patch)
treea209cd9ed0fff6721b5d171065b77a0e82893af6 /x11-plugins/wmtimer
parentInitial add of ebuild to portage (diff)
downloadgentoo-2-d2ceeb20b81c0c78dff73e829fbd50db694f0c25.tar.gz
gentoo-2-d2ceeb20b81c0c78dff73e829fbd50db694f0c25.tar.bz2
gentoo-2-d2ceeb20b81c0c78dff73e829fbd50db694f0c25.zip
Changed to CFLAGS are respected and cleaned up src_install()
Diffstat (limited to 'x11-plugins/wmtimer')
-rw-r--r--x11-plugins/wmtimer/ChangeLog5
-rw-r--r--x11-plugins/wmtimer/wmtimer-2.4.ebuild17
2 files changed, 17 insertions, 5 deletions
diff --git a/x11-plugins/wmtimer/ChangeLog b/x11-plugins/wmtimer/ChangeLog
index 65e5106c454b..4f6210a85d08 100644
--- a/x11-plugins/wmtimer/ChangeLog
+++ b/x11-plugins/wmtimer/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for x11-plugins/wmtimer
# Copyright 2001-2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.1 2002/09/16 16:14:04 raker Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/ChangeLog,v 1.2 2002/10/04 18:47:36 raker Exp $
* wmtimer-2.4 (12 August 2002)
+ 04 Oct 2002; Nick Hadaway <raker@gentoo.org> wmtimer-2.4.ebuild :
+ Added CFLAG optimizations and cleaned up src_install()
+
16 Sep 2002; Nick Hadaway <raker@gentoo.org> :
Moved from app-misc to x11-plugins.
diff --git a/x11-plugins/wmtimer/wmtimer-2.4.ebuild b/x11-plugins/wmtimer/wmtimer-2.4.ebuild
index 9cc277b82214..a11eafdb5389 100644
--- a/x11-plugins/wmtimer/wmtimer-2.4.ebuild
+++ b/x11-plugins/wmtimer/wmtimer-2.4.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.4.ebuild,v 1.2 2002/10/04 06:46:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtimer/wmtimer-2.4.ebuild,v 1.3 2002/10/04 18:47:36 raker Exp $
S=${WORKDIR}/${P}
S2=${S}/wmtimer
+
DESCRIPTION="Dockable clock which can run in alarm, countdown timer or chronograph mode"
SRC_URI="http://home.dwave.net/~jking/wmtimer/${P}.tar.gz"
HOMEPAGE="http://home.dwave.net/~jking/wmtimer/"
@@ -16,13 +17,21 @@ DEPEND="virtual/x11"
RDEPEND="${DEPEND}"
src_compile() {
+
cd ${S2}
+ cp Makefile Makefile.orig
+ sed -e "s:-O2 -Wall:${CFLAGS}:" Makefile.orig > Makefile
+
emake || die
+
}
src_install () {
- exeinto /usr/bin
- doexe ${S2}/wmtimer
+
+ cd ${S2}
+ dobin wmtimer
+
cd ${S}
- dodoc README COPYING INSTALL CREDITS INSTALL Changelog
+ dodoc README COPYING INSTALL CREDITS INSTALL Changelog
+
}