summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-01-31 20:43:37 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-01-31 20:43:37 +0000
commitd89d49b95bd693c2dede00c9d75019267ea54133 (patch)
tree776e9eb58444b18ad50654db45663498fde0af58 /x11-plugins/wmsmixer
parentMark 0.38 stable on alpha (diff)
downloadgentoo-2-d89d49b95bd693c2dede00c9d75019267ea54133.tar.gz
gentoo-2-d89d49b95bd693c2dede00c9d75019267ea54133.tar.bz2
gentoo-2-d89d49b95bd693c2dede00c9d75019267ea54133.zip
Fixed DEPEND for modular X.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-plugins/wmsmixer')
-rw-r--r--x11-plugins/wmsmixer/ChangeLog8
-rw-r--r--x11-plugins/wmsmixer/files/digest-wmsmixer-0.51
-rw-r--r--x11-plugins/wmsmixer/files/gcc3.diff12
-rw-r--r--x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild16
-rw-r--r--x11-plugins/wmsmixer/wmsmixer-0.5.ebuild35
5 files changed, 18 insertions, 54 deletions
diff --git a/x11-plugins/wmsmixer/ChangeLog b/x11-plugins/wmsmixer/ChangeLog
index 0513c0d8be48..e96b2916bb7b 100644
--- a/x11-plugins/wmsmixer/ChangeLog
+++ b/x11-plugins/wmsmixer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmsmixer
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/ChangeLog,v 1.18 2005/08/16 10:10:59 s4t4n Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/ChangeLog,v 1.19 2006/01/31 20:40:38 nelchael Exp $
+
+ 31 Jan 2006; Krzysiek Pawlik <nelchael@gentoo.org> -files/gcc3.diff,
+ -wmsmixer-0.5.ebuild, wmsmixer-0.5.1.ebuild:
+ Fixed DEPEND for modular X.
16 Aug 2005; Michele Noberasco <s4t4n@gentoo.org> wmsmixer-0.5.1.ebuild,
wmsmixer-0.5.ebuild:
diff --git a/x11-plugins/wmsmixer/files/digest-wmsmixer-0.5 b/x11-plugins/wmsmixer/files/digest-wmsmixer-0.5
deleted file mode 100644
index ec531d5c740b..000000000000
--- a/x11-plugins/wmsmixer/files/digest-wmsmixer-0.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8b4d739832a6b2b6c107d0eddad56cca wmsmixer-0.5.tar.gz 26208
diff --git a/x11-plugins/wmsmixer/files/gcc3.diff b/x11-plugins/wmsmixer/files/gcc3.diff
deleted file mode 100644
index 098dbb5ee3a9..000000000000
--- a/x11-plugins/wmsmixer/files/gcc3.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN wmsmixer-0.5/wmsmixer.cc wmsmixer-0.5-modified/wmsmixer.cc
---- wmsmixer-0.5/wmsmixer.cc 2001-03-05 16:39:43.000000000 -0600
-+++ wmsmixer-0.5-modified/wmsmixer.cc 2002-10-04 10:48:24.000000000 -0500
-@@ -547,7 +547,7 @@
- }
- }
-
--void checkVol(bool forced=true)
-+void checkVol(bool forced)
- {
- mixctl->readVol(channel[curchannel], true);
- int nl=mixctl->readLeft(channel[curchannel]);
diff --git a/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
index d4e782a36246..008321839244 100644
--- a/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
+++ b/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild,v 1.8 2005/08/16 10:10:59 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/wmsmixer-0.5.1.ebuild,v 1.9 2006/01/31 20:40:38 nelchael Exp $
inherit eutils
IUSE=""
@@ -12,8 +12,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
-DEPEND="virtual/libc
- virtual/x11"
+RDEPEND="|| ( (
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11 )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xproto
+ x11-proto/xextproto )
+ virtual/x11 )"
src_compile() {
g++ ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
diff --git a/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild b/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild
deleted file mode 100644
index 3b642dbfcc47..000000000000
--- a/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild,v 1.12 2005/08/16 10:10:59 s4t4n Exp $
-
-inherit eutils
-IUSE=""
-DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
-HOMEPAGE="http://www.hibernaculum.net/wmsmixer/index.php"
-SRC_URI="http://www.hibernaculum.net/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 amd64 ~sparc"
-
-DEPEND="virtual/libc
- virtual/x11"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/gcc3.diff
-}
-
-src_compile() {
- g++ -m32 ${CFLAGS} -I/usr/X11R6/include -c -o wmsmixer.o wmsmixer.cc
- rm -f wmsmixer
- g++ -o wmsmixer ${CFLAGS} -L/usr/X11R6/lib wmsmixer.o -lXpm -lXext -lX11
-}
-
-src_install() {
- insinto /usr/X11R6/bin
- insopts -m0655
- doins wmsmixer
- dodoc README README.wmmixer
-}