summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-14 18:27:43 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-14 18:27:43 +0000
commit49fdd395127cbad9d5158a3ee6b84c18a90d7531 (patch)
tree1cde50cae413fffb2c07345c4ae6324e162c6671 /x11-plugins/wmping/wmping-0.2.1.ebuild
parent Removed spanish manual (incomplete), added english one on mirror (closing bu... (diff)
downloadgentoo-2-49fdd395127cbad9d5158a3ee6b84c18a90d7531.tar.gz
gentoo-2-49fdd395127cbad9d5158a3ee6b84c18a90d7531.tar.bz2
gentoo-2-49fdd395127cbad9d5158a3ee6b84c18a90d7531.zip
initial commit
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmping/wmping-0.2.1.ebuild')
-rw-r--r--x11-plugins/wmping/wmping-0.2.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmping/wmping-0.2.1.ebuild b/x11-plugins/wmping/wmping-0.2.1.ebuild
new file mode 100644
index 000000000000..72142eb626c1
--- /dev/null
+++ b/x11-plugins/wmping/wmping-0.2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmping/wmping-0.2.1.ebuild,v 1.1 2008/01/14 18:27:42 drac Exp $
+
+DESCRIPTION="a simple host status monitoring dockapp."
+HOMEPAGE="http://sourceforge.net/projects/wmping"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="suid"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libICE
+ x11-libs/libXt"
+
+src_install() {
+ if use suid; then
+ emake DESTDIR="${D}" install || die "emake failed."
+ else
+ dosbin ${PN}
+ fi
+
+ doman ${PN}.1
+ dodoc AUTHORS CHANGES README
+}
+
+pkg_postinst() {
+ use suid || ewarn "warning, ${PN} needs to be executed root for functionality."
+}