summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-09-26 10:44:09 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-09-26 10:44:09 +0000
commit93c016b0d0fbb71255ee0f5d8349855cf767fad2 (patch)
tree457c5806ba09fb8e4f47b892e14b7b6fccc5df8e /x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
parentremoved old scribus ebuilds (diff)
downloadgentoo-2-93c016b0d0fbb71255ee0f5d8349855cf767fad2.tar.gz
gentoo-2-93c016b0d0fbb71255ee0f5d8349855cf767fad2.tar.bz2
gentoo-2-93c016b0d0fbb71255ee0f5d8349855cf767fad2.zip
Revision bump, updating libdockapp dependancy. Closes bug #105530
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild')
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..8fad5a6de0a8
--- /dev/null
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmlpq/wmlpq-0.2.1-r1.ebuild,v 1.1 2005/09/26 10:44:09 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
+SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
+HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
+
+DEPEND="virtual/x11
+ =x11-libs/libdockapp-0.5.0-r1"
+
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-makefile.patch
+}
+
+src_install()
+{
+ dodir /usr/bin/
+ einstall DESTDIR=${D}/usr/bin/ CFLAGS="${CFLAGS} -Wall" || die "Installation failed"
+
+ dodoc README sample.wmlpqrc
+ newman wmlpq.1x wmlpq.1
+
+ insinto /usr/share/applications
+ doins ${FILESDIR}/${PN}.desktop
+}