summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2006-01-22 02:21:35 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2006-01-22 02:21:35 +0000
commit0369d3bae1b06dcc658c04398ececca42ff8ecb2 (patch)
treeb8cbaa2f5cc5f39a30fceabdfe1199e15961711c /x11-plugins/wmium/wmium-1.0.9b-r1.ebuild
parentStable on sparc (diff)
downloadgentoo-2-0369d3bae1b06dcc658c04398ececca42ff8ecb2.tar.gz
gentoo-2-0369d3bae1b06dcc658c04398ececca42ff8ecb2.tar.bz2
gentoo-2-0369d3bae1b06dcc658c04398ececca42ff8ecb2.zip
Make modular X friendly, remove media-libs/xpm dependency
(Portage version: 2.0.54)
Diffstat (limited to 'x11-plugins/wmium/wmium-1.0.9b-r1.ebuild')
-rw-r--r--x11-plugins/wmium/wmium-1.0.9b-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-plugins/wmium/wmium-1.0.9b-r1.ebuild b/x11-plugins/wmium/wmium-1.0.9b-r1.ebuild
new file mode 100644
index 000000000000..6106135af8da
--- /dev/null
+++ b/x11-plugins/wmium/wmium-1.0.9b-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmium/wmium-1.0.9b-r1.ebuild,v 1.1 2006/01/22 02:21:35 vanquirius Exp $
+
+IUSE="gtk"
+
+DESCRIPTION="WindowMaker DockApp/Grellm2 plugin that fetches the DSL usage information for Australian ISP Internode"
+HOMEPAGE="http://www.earthmagic.org/?software"
+SRC_URI="http://www.earthmagic.org/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/libc
+ dev-libs/openssl
+ gtk? (
+ >=x11-libs/gtk+-2
+ app-admin/gkrellm
+ dev-util/pkgconfig
+ )
+ ( || (
+ ( >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXext-1.0.0
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xextproto-7.0.2 )
+ virtual/x11 )
+ )"
+
+RDEPEND="virtual/libc
+ dev-libs/openssl
+ gtk? (
+ >=x11-libs/gtk+-2
+ app-admin/gkrellm
+ )
+ !gtk? ( x11-wm/windowmaker )
+ ( || (
+ ( >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXext-1.0.0
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-proto/xextproto-7.0.2 )
+ virtual/x11 )
+ )"
+
+src_compile() {
+ emake build || die
+ if use gtk; then
+ emake build-gk2 || die
+ fi
+}
+
+src_install() {
+ if use gtk; then
+ exeinto /usr/lib/gkrellm2/plugins
+ doexe src-gk2/wmium-gk2.so
+ fi
+
+ dobin src/wmium
+
+ dodoc BUGS INSTALL-GK2 README dot.wmiumrc.sample \
+ CHANGES INSTALL README-GK2
+
+ doman src/wmium.1
+
+ einfo
+ einfo "To configure look at the /usr/share/doc/${PF}/dot.wmiumrc.sample"
+ einfo "(if using /usr/bin/wmium with WINDOWMAKER ONLY)"
+ einfo
+ einfo "or use the preferences within gkrellm2"
+}
+