summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-12-13 09:37:01 +0000
committerMichael Weber <xmw@gentoo.org>2010-12-13 09:37:01 +0000
commit22f31ab1c8ca50db2af7f52eb38e6434311bbf30 (patch)
tree34c23b5c8fcc1822b25e98d802fbf6ef6656c4b1 /x11-plugins/wmfrog/wmfrog-0.3.1.ebuild
parentFix app-text/rman dependency (bug 348568) (diff)
downloadgentoo-2-22f31ab1c8ca50db2af7f52eb38e6434311bbf30.tar.gz
gentoo-2-22f31ab1c8ca50db2af7f52eb38e6434311bbf30.tar.bz2
gentoo-2-22f31ab1c8ca50db2af7f52eb38e6434311bbf30.zip
Version bump (bug 348563)
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmfrog/wmfrog-0.3.1.ebuild')
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.3.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild b/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild
new file mode 100644
index 000000000000..c9aebd6c2594
--- /dev/null
+++ b/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfrog/wmfrog-0.3.1.ebuild,v 1.1 2010/12/13 09:37:01 xmw Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="a weather application, it shows the weather in a graphical way."
+HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/Src
+
+src_prepare() {
+ emake clean || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
+ LIBDIR="" SYSTEM="${LDFLAGS}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ../{CHANGES,HINTS} || die
+}