summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-07-06 08:21:57 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-07-06 08:21:57 +0000
commit7b9077fe199ddd87a6ee0a64f91e48f4e161ccf4 (patch)
tree59516cb1eb50519cceb081c12cbdf6ec1c176ba0 /x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild
parentRemoved unused/dupe useflags for scientific Packages. (diff)
downloadgentoo-2-7b9077fe199ddd87a6ee0a64f91e48f4e161ccf4.tar.gz
gentoo-2-7b9077fe199ddd87a6ee0a64f91e48f4e161ccf4.tar.bz2
gentoo-2-7b9077fe199ddd87a6ee0a64f91e48f4e161ccf4.zip
Revision bump, closing bug #97856
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild')
-rw-r--r--x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild b/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..281ca4f0c29a
--- /dev/null
+++ b/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmdf/wmdf-0.1.6-r1.ebuild,v 1.1 2005/07/06 08:21:57 s4t4n Exp $
+
+inherit eutils
+
+IUSE=""
+
+DESCRIPTION="An app to monitor disk space on partitions"
+SRC_URI="http://dockapps.org/download.php/id/359/${P}.tar.gz"
+HOMEPAGE="http://dockapps.org/file.php/id/175"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc ppc64 ~sparc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+
+ # Remove special filesystem entries, see bug #97856
+ epatch ${FILESDIR}/wmdf_sys-fs.patch
+
+ # Remove non-implemented command line args from 'wmdf -h' listing
+ epatch ${FILESDIR}/wmdf_cmd_line_args.patch
+}
+
+src_compile() {
+ econf || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc README AUTHORS COPYING ChangeLog NEWS THANKS TODO INSTALL
+}