summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2009-08-22 19:38:59 +0000
committerJim Ramsay <lack@gentoo.org>2009-08-22 19:38:59 +0000
commitb56542dd62c14be91b22980586dfd429f268498c (patch)
treef1bcbf36ffeab93feb72ed6c4faf32f1af65f4d2 /x11-plugins/screenlets
parentVersion bump (diff)
downloadgentoo-2-b56542dd62c14be91b22980586dfd429f268498c.tar.gz
gentoo-2-b56542dd62c14be91b22980586dfd429f268498c.tar.bz2
gentoo-2-b56542dd62c14be91b22980586dfd429f268498c.zip
New package: Screenlets-0.1.2 (Bug #212448)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'x11-plugins/screenlets')
-rw-r--r--x11-plugins/screenlets/ChangeLog11
-rw-r--r--x11-plugins/screenlets/metadata.xml25
-rw-r--r--x11-plugins/screenlets/screenlets-0.1.2.ebuild40
3 files changed, 76 insertions, 0 deletions
diff --git a/x11-plugins/screenlets/ChangeLog b/x11-plugins/screenlets/ChangeLog
new file mode 100644
index 000000000000..243a917fce5c
--- /dev/null
+++ b/x11-plugins/screenlets/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-plugins/screenlets
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/screenlets/ChangeLog,v 1.1 2009/08/22 19:38:59 lack Exp $
+
+*screenlets-0.1.2 (22 Aug 2009)
+
+ 22 Aug 2009; Jim Ramsay <lack@gentoo.org> +screenlets-0.1.2.ebuild,
+ +metadata.xml:
+ New package: Screenlets is another desktop applet thing, like desklets...
+ only newer ;) Bug #212448
+
diff --git a/x11-plugins/screenlets/metadata.xml b/x11-plugins/screenlets/metadata.xml
new file mode 100644
index 000000000000..a1947ab7e87b
--- /dev/null
+++ b/x11-plugins/screenlets/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop</herd>
+ <maintainer>
+ <email>lack@gentoo.org</email>
+ <name>Jim Ramsay</name>
+ </maintainer>
+ <longdescription lang="en">
+ Screenlets are small owner-drawn applications (written in Python) that
+ can be described as "the virtual representation of things lying/standing
+ around on your desk". Sticknotes, clocks, rulers, ... the possibilities
+ are endless.
+
+ The goal of the Screenlets base-classes is to simplify the creation of
+ fully themeable mini-apps that each solve basic desktop-work-related
+ needs and generally improve the usability and eye-candy of the modern
+ composited Linux-desktop.
+ </longdescription>
+ <use>
+ <flag name="svg">Highly Recommended: Enable SVG graphics via
+ <pkg>dev-python/librsvg-python</pkg></flag>
+ </use>
+</pkgmetadata>
+
diff --git a/x11-plugins/screenlets/screenlets-0.1.2.ebuild b/x11-plugins/screenlets/screenlets-0.1.2.ebuild
new file mode 100644
index 000000000000..d949d49e0f27
--- /dev/null
+++ b/x11-plugins/screenlets/screenlets-0.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/screenlets/screenlets-0.1.2.ebuild,v 1.1 2009/08/22 19:38:59 lack Exp $
+
+EAPI=2
+inherit eutils distutils
+
+DESCRIPTION="Screenlets are small owner-drawn applications"
+HOMEPAGE="http://www.screenlets.org"
+SRC_URI="http://code.launchpad.net/screenlets/trunk/${PV}/+download/screenlets-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+svg"
+
+RDEPEND="dev-python/dbus-python
+ svg? ( dev-python/librsvg-python )
+ dev-python/libwnck-python
+ dev-python/gnome-keyring-python
+ dev-python/pyxdg
+ x11-libs/libnotify
+ x11-misc/xdg-utils"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/desktop-directories
+ doins "${S}"/desktop-menu/desktop-directories/Screenlets.directory
+
+ insinto /usr/share/icons
+ doins "${S}"/desktop-menu/screenlets.svg
+
+ # Insert .desktop files
+ for x in $(find "${S}"/desktop-menu -name "*.desktop"); do
+ domenu ${x}
+ done
+}