summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-08-10 15:43:44 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-08-10 15:43:44 +0000
commit01cfa05f35013ba4d50bf8dbd5a1514df35b8c11 (patch)
tree652510453e1ab7330b050dd70bc45d30a81b2da9 /x11-plugins/pidgin-opensteamworks
parentVersion bump (diff)
downloadgentoo-2-01cfa05f35013ba4d50bf8dbd5a1514df35b8c11.tar.gz
gentoo-2-01cfa05f35013ba4d50bf8dbd5a1514df35b8c11.tar.bz2
gentoo-2-01cfa05f35013ba4d50bf8dbd5a1514df35b8c11.zip
Version bump. Drop old.
(Portage version: 2.1.13.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'x11-plugins/pidgin-opensteamworks')
-rw-r--r--x11-plugins/pidgin-opensteamworks/ChangeLog9
-rw-r--r--x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p67-Makefile29
-rw-r--r--x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p67.ebuild (renamed from x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild)8
3 files changed, 42 insertions, 4 deletions
diff --git a/x11-plugins/pidgin-opensteamworks/ChangeLog b/x11-plugins/pidgin-opensteamworks/ChangeLog
index 9f8fed4717aa..0469f4a76928 100644
--- a/x11-plugins/pidgin-opensteamworks/ChangeLog
+++ b/x11-plugins/pidgin-opensteamworks/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/pidgin-opensteamworks
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.17 2013/07/08 16:27:36 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/ChangeLog,v 1.18 2013/08/10 15:43:44 mrueg Exp $
+
+*pidgin-opensteamworks-1.0_p67 (10 Aug 2013)
+
+ 10 Aug 2013; Manuel Rüger <mrueg@gentoo.org>
+ +files/pidgin-opensteamworks-1.0_p67-Makefile,
+ +pidgin-opensteamworks-1.0_p67.ebuild, -pidgin-opensteamworks-1.0_p38.ebuild:
+ Version bump. Drop old.
08 Jul 2013; Manuel Rüger <mrueg@gentoo.org>
-pidgin-opensteamworks-1.0_p32.ebuild, -pidgin-opensteamworks-1.0_p34.ebuild,
diff --git a/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p67-Makefile b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p67-Makefile
new file mode 100644
index 000000000000..15beba3ed032
--- /dev/null
+++ b/x11-plugins/pidgin-opensteamworks/files/pidgin-opensteamworks-1.0_p67-Makefile
@@ -0,0 +1,29 @@
+CC ?= gcc
+
+PLUGINDIR ?= $(shell pkg-config --variable=plugindir purple)
+
+CFLAGS += -Wall -fPIC
+LDFLAGS += -shared
+CPPFLAGS += $(shell pkg-config --cflags glib-2.0 json-glib-1.0 purple nss gnome-keyring-1)
+LIBS += $(shell pkg-config --libs glib-2.0 json-glib-1.0 purple nss)
+
+TARGET = libsteam.so
+
+OBJS = libsteam.o steam_connection.o
+
+%.o: %.c %.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $*.c
+
+$(TARGET): $(OBJS)
+ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $(OBJS) $(LIBS)
+
+install: $(TARGET)
+ @install -Dm755 $(TARGET) "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
+
+uninstall:
+ @rm -f "$(DESTDIR)$(PLUGINDIR)/$(TARGET)"
+
+clean:
+ @rm -f $(OBJS) $(TARGET)
+
+.PHONY: uninstall clean
diff --git a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p67.ebuild
index a7255512e690..58a46126f91b 100644
--- a/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild
+++ b/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p67.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p38.ebuild,v 1.1 2013/01/29 19:34:57 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-opensteamworks/pidgin-opensteamworks-1.0_p67.ebuild,v 1.1 2013/08/10 15:43:44 mrueg Exp $
EAPI=5
@@ -8,7 +8,7 @@ inherit toolchain-funcs
DESCRIPTION="Steam protocol plugin for pidgin"
HOMEPAGE="http://code.google.com/p/pidgin-opensteamworks/"
-SRC_URI="http://dev.gentoo.org/~hasufell/distfiles/${P}.tar.xz
+SRC_URI="http://dev.gentoo.org/~mrueg/distfiles/${P}.tar.xz
http://pidgin-opensteamworks.googlecode.com/files/icons.zip
-> ${PN}-icons.zip"
@@ -19,6 +19,8 @@ IUSE=""
RDEPEND="dev-libs/glib:2
dev-libs/json-glib
+ dev-libs/nss
+ gnome-base/libgnome-keyring
net-im/pidgin"
DEPEND="${RDEPEND}
app-arch/unzip
@@ -31,7 +33,7 @@ pkg_setup() {
src_prepare() {
# see http://code.google.com/p/pidgin-opensteamworks/issues/detail?id=31
- cp "${FILESDIR}"/${PN}-1.0_p32-Makefile "${S}"/Makefile || die
+ cp "${FILESDIR}"/${P}-Makefile "${S}"/Makefile || die
}
src_install() {