summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-02-15 23:46:05 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-02-15 23:46:05 +0000
commit0125236bf1983d8284ebb5d4103f266c5e62429d (patch)
tree0a0d02d1d9a0ba21288f67218e83a316b3ff137c /x11-plugins/pidgin-msn-pecan
parentDo not build with headers by default for avr #230343. (diff)
downloadgentoo-2-0125236bf1983d8284ebb5d4103f266c5e62429d.tar.gz
gentoo-2-0125236bf1983d8284ebb5d4103f266c5e62429d.tar.bz2
gentoo-2-0125236bf1983d8284ebb5d4103f266c5e62429d.zip
Version bump, bugfixes including personal status messages, adds voice clip support, remove Makefile sed for multilib as it's not longer needed and breaks things in this version
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/pidgin-msn-pecan')
-rw-r--r--x11-plugins/pidgin-msn-pecan/ChangeLog12
-rw-r--r--x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.18.ebuild41
2 files changed, 51 insertions, 2 deletions
diff --git a/x11-plugins/pidgin-msn-pecan/ChangeLog b/x11-plugins/pidgin-msn-pecan/ChangeLog
index 81b2aa12d977..f8caadd0f319 100644
--- a/x11-plugins/pidgin-msn-pecan/ChangeLog
+++ b/x11-plugins/pidgin-msn-pecan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/pidgin-msn-pecan
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-msn-pecan/ChangeLog,v 1.5 2008/12/01 14:46:11 voyageur Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-msn-pecan/ChangeLog,v 1.6 2009/02/15 23:46:05 voyageur Exp $
+
+*pidgin-msn-pecan-0.0.18 (15 Feb 2009)
+
+ 15 Feb 2009; Bernard Cafarelli <voyageur@gentoo.org>
+ +pidgin-msn-pecan-0.0.18.ebuild:
+ Version bump, bugfixes including personal status messages, adds voice clip
+ support, remove Makefile sed for multilib as it's not longer needed and
+ breaks things in this version
*pidgin-msn-pecan-0.0.17 (01 Dec 2008)
diff --git a/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.18.ebuild b/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.18.ebuild
new file mode 100644
index 000000000000..804436ebff85
--- /dev/null
+++ b/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.18.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-msn-pecan/pidgin-msn-pecan-0.0.18.ebuild,v 1.1 2009/02/15 23:46:05 voyageur Exp $
+
+inherit toolchain-funcs multilib
+
+MY_P="msn-pecan-${PV}"
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc COPYRIGHT ChangeLog README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}