summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-08-11 13:50:11 +0000
committerJim Ramsay <lack@gentoo.org>2010-08-11 13:50:11 +0000
commit74ff7e8089831959afcf1e571d3c8c56ebdd7e31 (patch)
tree05286d6fede9fa1db6ccebf7202aefe07320e470 /x11-plugins/gkrellm-volume
parentMoved from sunrise overaly. Thanks to Chad A. Simmons <chad.simmons@member.fs... (diff)
downloadgentoo-2-74ff7e8089831959afcf1e571d3c8c56ebdd7e31.tar.gz
gentoo-2-74ff7e8089831959afcf1e571d3c8c56ebdd7e31.tar.bz2
gentoo-2-74ff7e8089831959afcf1e571d3c8c56ebdd7e31.zip
Respect LDFLAGS (Bug #332107)
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/gkrellm-volume')
-rw-r--r--x11-plugins/gkrellm-volume/ChangeLog9
-rw-r--r--x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch13
-rw-r--r--x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild32
3 files changed, 53 insertions, 1 deletions
diff --git a/x11-plugins/gkrellm-volume/ChangeLog b/x11-plugins/gkrellm-volume/ChangeLog
index e4f079c7d3aa..e43b9ea222b3 100644
--- a/x11-plugins/gkrellm-volume/ChangeLog
+++ b/x11-plugins/gkrellm-volume/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/gkrellm-volume
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-volume/ChangeLog,v 1.31 2010/07/29 14:17:44 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-volume/ChangeLog,v 1.32 2010/08/11 13:50:11 lack Exp $
+
+*gkrellm-volume-2.1.13-r2 (11 Aug 2010)
+
+ 11 Aug 2010; Jim Ramsay <lack@gentoo.org>
+ +gkrellm-volume-2.1.13-r2.ebuild,
+ +files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch:
+ Respect LDFLAGS (Bug #332107)
*gkrellm-volume-2.1.13-r1 (29 Jul 2010)
diff --git a/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch
new file mode 100644
index 000000000000..1d711fb74946
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-Respect-LDFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 7a9821d..db02cad 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,6 +18,8 @@ FLAGS = -O2 -Wall -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB)
+ LFLAGS = -shared
+
++LFLAGS += $(LDFLAGS)
++
+ OBJS = volume.o mixer.o oss_mixer.o
+
+ ifeq ($(enable_alsa),1)
diff --git a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
new file mode 100644
index 000000000000..74ac0afb361c
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r2.ebuild,v 1.1 2010/08/11 13:50:11 lack Exp $
+
+EAPI="3"
+inherit gkrellm-plugin eutils
+
+IUSE="alsa"
+DESCRIPTION="A mixer control plugin for gkrellm"
+HOMEPAGE="http://gkrellm.luon.net/volume.php"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+
+S=${WORKDIR}/${PN}
+
+PLUGIN_SO=volume.so
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-reenable.patch"
+ epatch "${FILESDIR}/${P}-Respect-LDFLAGS.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use alsa && myconf="${myconf} enable_alsa=1"
+ make ${myconf} || die "make failed"
+}