summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-02-10 20:33:46 +0000
committerDon Seiler <rizzo@gentoo.org>2005-02-10 20:33:46 +0000
commitb72bee4860abc431fc74cece41b99ac05be7c1f8 (patch)
tree32584c343432e76828e77fb403db5c76d58dd3ed /x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild
parentStable on ppc. (diff)
downloadgentoo-2-b72bee4860abc431fc74cece41b99ac05be7c1f8.tar.gz
gentoo-2-b72bee4860abc431fc74cece41b99ac05be7c1f8.tar.bz2
gentoo-2-b72bee4860abc431fc74cece41b99ac05be7c1f8.zip
Version bump
(Portage version: 2.0.51.16)
Diffstat (limited to 'x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild')
-rw-r--r--x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild b/x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild
new file mode 100644
index 000000000000..f510846c900b
--- /dev/null
+++ b/x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-otr/gaim-otr-2.0.0.ebuild,v 1.1 2005/02/10 20:33:46 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="(OTR) Messaging allows you to have private conversations over instant messaging"
+HOMEPAGE="http://www.cypherpunks.ca/otr/"
+SRC_URI="http://www.cypherpunks.ca/otr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=net-libs/libotr-2.0.0
+ >=net-im/gaim-1.1.0"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc COPYING ChangeLog README
+}