summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-08-25 15:41:16 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-08-25 15:41:16 +0000
commit2c863183f7f6edabf7f607ab32db4a162266ab72 (patch)
tree3bde761c93f336ee5b61fe4ad25785a8a8ab883a /x11-plugins/asclock
parentLinux patch 2.6.32.20. Removal of redundant patch. (diff)
downloadgentoo-2-2c863183f7f6edabf7f607ab32db4a162266ab72.tar.gz
gentoo-2-2c863183f7f6edabf7f607ab32db4a162266ab72.tar.bz2
gentoo-2-2c863183f7f6edabf7f607ab32db4a162266ab72.zip
Migrate changes from Gentoo Prefix overlay. KEYWORDS, EAPI3, CFLAG handling. Approved by maintainer
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/asclock')
-rw-r--r--x11-plugins/asclock/ChangeLog8
-rw-r--r--x11-plugins/asclock/asclock-2.0.12-r1.ebuild29
2 files changed, 22 insertions, 15 deletions
diff --git a/x11-plugins/asclock/ChangeLog b/x11-plugins/asclock/ChangeLog
index c5445b9b839f..fa5c22e54a84 100644
--- a/x11-plugins/asclock/ChangeLog
+++ b/x11-plugins/asclock/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/asclock
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/ChangeLog,v 1.22 2009/11/03 15:27:09 voyageur Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/ChangeLog,v 1.23 2010/08/25 15:41:16 darkside Exp $
+
+ 25 Aug 2010; Jeremy Olexa <darkside@gentoo.org> asclock-2.0.12-r1.ebuild:
+ Migrate changes from Gentoo Prefix overlay. KEYWORDS, EAPI3, CFLAG
+ handling. Approved by maintainer
03 Nov 2009; Bernard Cafarelli <voyageur@gentoo.org>
asclock-2.0.12-r1.ebuild:
diff --git a/x11-plugins/asclock/asclock-2.0.12-r1.ebuild b/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
index c4325d4cb90f..d531fc52d97d 100644
--- a/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
+++ b/x11-plugins/asclock/asclock-2.0.12-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/asclock-2.0.12-r1.ebuild,v 1.8 2009/11/03 15:27:09 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asclock/asclock-2.0.12-r1.ebuild,v 1.9 2010/08/25 15:41:16 darkside Exp $
+EAPI=3
inherit eutils toolchain-funcs
IUSE=""
@@ -10,31 +11,33 @@ SRC_URI="http://www.tigr.net/afterstep/download/asclock/${P}.tar.gz"
HOMEPAGE="http://www.tigr.net/afterstep/list.pl"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~mips ppc sparc x86"
+KEYWORDS="~amd64 ~mips ppc sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
DEPEND="x11-libs/libXpm"
RDEPEND="${DEPEND}
x11-proto/xextproto
x11-proto/xproto"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-gcc41.patch
ln -s themes/classic default_theme
}
+src_configure() { :; }
+
src_compile() {
local x
+ # will break Solaris
+ [[ ${CHOST} == *-linux-gnu ]] && CFLAGS="${CFLAGS} \
+ -Dlinux \
+ -D_POSIX_C_SOURCE=199309L \
+ -D_POSIX_SOURCE \
+ -D_XOPEN_SOURCE"
for x in asclock parser symbols config
do
$(tc-getCC) \
${CPPFLAGS} ${CFLAGS} ${ASFLAGS} \
- -I/usr/include \
- -Dlinux \
- -D_POSIX_C_SOURCE=199309L \
- -D_POSIX_SOURCE \
- -D_XOPEN_SOURCE \
+ -I"${EPREFIX}"/usr/include \
-D_BSD_SOURCE \
-D_SVID_SOURCE \
-DFUNCPROTO=15 \
@@ -45,8 +48,8 @@ src_compile() {
${LDFLAGS} \
-o asclock \
asclock.o parser.o symbols.o config.o \
- -L/usr/lib \
- -L/usr/lib/X11 \
+ -L"${EPREFIX}"/usr/lib \
+ -L"${EPREFIX}"/usr/lib/X11 \
-lXpm -lXext -lX11 || die "link asclock failed"
}