summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-09-24 20:33:42 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-09-24 20:33:42 +0000
commitf05047a7c3f92ac4f82b71197361a9e10a687950 (patch)
treeb10850c397d993df6ea2a95eae24f6a1ad9a60cb /x11-misc
parentStable for X86, wrt bug #424435 (diff)
downloadgentoo-2-f05047a7c3f92ac4f82b71197361a9e10a687950.tar.gz
gentoo-2-f05047a7c3f92ac4f82b71197361a9e10a687950.tar.bz2
gentoo-2-f05047a7c3f92ac4f82b71197361a9e10a687950.zip
version bump
(Portage version: 2.2.0_alpha131/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wbar/ChangeLog7
-rw-r--r--x11-misc/wbar/wbar-2.3.4.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-misc/wbar/ChangeLog b/x11-misc/wbar/ChangeLog
index b37dc96ec184..433610efd075 100644
--- a/x11-misc/wbar/ChangeLog
+++ b/x11-misc/wbar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/wbar
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.25 2012/09/21 21:53:30 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.26 2012/09/24 20:33:42 hasufell Exp $
+
+*wbar-2.3.4 (24 Sep 2012)
+
+ 24 Sep 2012; Julian Ospald <hasufell@gentoo.org> +wbar-2.3.4.ebuild:
+ version bump
21 Sep 2012; Julian Ospald <hasufell@gentoo.org> wbar-2.3.3.ebuild,
+files/wbar-2.3.3-test.patch:
diff --git a/x11-misc/wbar/wbar-2.3.4.ebuild b/x11-misc/wbar/wbar-2.3.4.ebuild
new file mode 100644
index 000000000000..f9b02aa66ad4
--- /dev/null
+++ b/x11-misc/wbar/wbar-2.3.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.3.4.ebuild,v 1.1 2012/09/24 20:33:42 hasufell Exp $
+
+EAPI=4
+
+inherit autotools eutils
+
+DESCRIPTION="A fast, lightweight quick launch bar"
+HOMEPAGE="http://code.google.com/p/wbar/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="media-libs/imlib2[X]
+ virtual/init
+ x11-libs/libX11
+ gtk? ( gnome-base/libglade
+ media-libs/freetype:2
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ use gtk || epatch "${FILESDIR}"/${PN}-2.3.3-cfg.patch
+ epatch "${FILESDIR}"/${PN}-2.3.3-{desktopfile,nowerror,test}.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gtk wbar-config)
+}