summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-08 08:26:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-08 08:26:04 +0000
commite630a4f38b65b4d5db6e1fdb2e138c5645055f54 (patch)
tree0cebabdca113031725fd236340960b0d8d227674 /x11-misc
parenttargets/developer/make.defaults: (diff)
downloadgentoo-2-e630a4f38b65b4d5db6e1fdb2e138c5645055f54.tar.gz
gentoo-2-e630a4f38b65b4d5db6e1fdb2e138c5645055f54.tar.bz2
gentoo-2-e630a4f38b65b4d5db6e1fdb2e138c5645055f54.zip
Fix "make install" with latest coreutils wrt #327353 by Michael M. Tung.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xdialog/ChangeLog8
-rw-r--r--x11-misc/xdialog/files/xdialog-2.3.1-install.patch13
-rw-r--r--x11-misc/xdialog/xdialog-2.3.1.ebuild26
3 files changed, 32 insertions, 15 deletions
diff --git a/x11-misc/xdialog/ChangeLog b/x11-misc/xdialog/ChangeLog
index 3ce14830aa42..a9dab06901de 100644
--- a/x11-misc/xdialog/ChangeLog
+++ b/x11-misc/xdialog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xdialog
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdialog/ChangeLog,v 1.28 2009/02/22 15:56:19 nelchael Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdialog/ChangeLog,v 1.29 2010/07/08 08:26:04 ssuominen Exp $
+
+ 08 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> xdialog-2.3.1.ebuild,
+ +files/xdialog-2.3.1-install.patch:
+ Fix "make install" with latest coreutils wrt #327353 by Michael M. Tung.
22 Feb 2009; Krzysiek Pawlik <nelchael@gentoo.org>
-xdialog-2.2.1-r1.ebuild:
diff --git a/x11-misc/xdialog/files/xdialog-2.3.1-install.patch b/x11-misc/xdialog/files/xdialog-2.3.1-install.patch
new file mode 100644
index 000000000000..f5a02b099d92
--- /dev/null
+++ b/x11-misc/xdialog/files/xdialog-2.3.1-install.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/327353
+
+--- doc/Makefile.am
++++ doc/Makefile.am
+@@ -6,7 +6,7 @@
+
+ CLEANFILES = index.html compatibility.html changelog.html license.html Xdialog.1
+
+-doc_DATA = index.html compatibility.html changelog.html license.html $(srcdir)/*.html $(srcdir)/*.png
++doc_DATA = $(srcdir)/*.html $(srcdir)/*.png
+
+ man_MANS = Xdialog.1
+
diff --git a/x11-misc/xdialog/xdialog-2.3.1.ebuild b/x11-misc/xdialog/xdialog-2.3.1.ebuild
index 064b7a318296..2f3c547edc23 100644
--- a/x11-misc/xdialog/xdialog-2.3.1.ebuild
+++ b/x11-misc/xdialog/xdialog-2.3.1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdialog/xdialog-2.3.1.ebuild,v 1.6 2009/02/15 13:48:42 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xdialog/xdialog-2.3.1.ebuild,v 1.7 2010/07/08 08:26:04 ssuominen Exp $
-inherit eutils autotools
+EAPI=2
+inherit autotools eutils
DESCRIPTION="drop-in replacement for cdialog using GTK"
HOMEPAGE="http://xdialog.dyns.net/"
@@ -13,27 +14,26 @@ SLOT="0"
KEYWORDS="alpha amd64 ~hppa ppc x86"
IUSE="doc examples nls"
-RDEPEND=">=x11-libs/gtk+-2.2"
+RDEPEND=">=x11-libs/gtk+-2.2:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig
nls? ( sys-devel/gettext )"
-S="${WORKDIR}/${P/x/X}"
+S=${WORKDIR}/${P/x/X}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${P}-no-strip.patch"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{no-strip,install}.patch
eautoreconf
}
-src_compile() {
- econf $(use_enable nls) --with-gtk2
- emake || die "emake failed."
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --with-gtk2
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
+ emake DESTDIR="${D}" install || die
rm -rf "${D}"/usr/share/doc
dodoc AUTHORS BUGS ChangeLog README