summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-28 20:54:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-28 20:54:49 +0000
commit7c07951051ed9246d93de96e39eb1a799555034f (patch)
tree9e1d530915370ba07c072d6984433cd53ecf5312 /x11-misc
parentVersion bump. Fixes bug #304419 (diff)
downloadgentoo-2-7c07951051ed9246d93de96e39eb1a799555034f.tar.gz
gentoo-2-7c07951051ed9246d93de96e39eb1a799555034f.tar.bz2
gentoo-2-7c07951051ed9246d93de96e39eb1a799555034f.zip
Revbump which fixes recent changes on python eclass. Fixes bug #317021
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pypanel/ChangeLog9
-rw-r--r--x11-misc/pypanel/pypanel-2.4-r1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/x11-misc/pypanel/ChangeLog b/x11-misc/pypanel/ChangeLog
index 3e0eb7a7f5d4..348ae3aa4d74 100644
--- a/x11-misc/pypanel/ChangeLog
+++ b/x11-misc/pypanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/pypanel
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/ChangeLog,v 1.38 2009/12/27 13:37:28 yngwin Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/ChangeLog,v 1.39 2010/05/28 20:54:49 hwoarang Exp $
+
+*pypanel-2.4-r1 (28 May 2010)
+
+ 28 May 2010; Markos Chandras <hwoarang@gentoo.org> +pypanel-2.4-r1.ebuild:
+ Revbump which fixes recent changes on python eclass. Fixes bug #317021
27 Dec 2009; Ben de Groot <yngwin@gentoo.org> pypanel-2.4.ebuild:
Add usedep on imlib2[X] (bug 297796). Some minor cleanups.
diff --git a/x11-misc/pypanel/pypanel-2.4-r1.ebuild b/x11-misc/pypanel/pypanel-2.4-r1.ebuild
new file mode 100644
index 000000000000..0e8dc1f5a4de
--- /dev/null
+++ b/x11-misc/pypanel/pypanel-2.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pypanel/pypanel-2.4-r1.ebuild,v 1.1 2010/05/28 20:54:49 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit distutils eutils
+
+MY_PN=${PN/pyp/PyP}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A lightweight panel/taskbar for X11 window managers"
+HOMEPAGE="http://pypanel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXft
+ dev-lang/python
+ dev-python/python-xlib
+ sys-apps/sed
+ media-libs/imlib2[X]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}