summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-28 21:10:04 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-28 21:10:04 +0000
commit6127084c1f9eb4ee6c1e48c91de8f11ac7808f16 (patch)
treec3e5ce2c5bcbd9ebf404f9aae820a704b82d3c3f /x11-misc
parentUse Python 2 (bug #313951). (diff)
downloadgentoo-2-6127084c1f9eb4ee6c1e48c91de8f11ac7808f16.tar.gz
gentoo-2-6127084c1f9eb4ee6c1e48c91de8f11ac7808f16.tar.bz2
gentoo-2-6127084c1f9eb4ee6c1e48c91de8f11ac7808f16.zip
Version bump. Fixes bug #309661
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xrmap/ChangeLog7
-rw-r--r--x11-misc/xrmap/files/xrmap-2.33-Makefile.kit.patch20
-rw-r--r--x11-misc/xrmap/files/xrmap-2.33-as-needed.patch13
-rw-r--r--x11-misc/xrmap/xrmap-2.33.ebuild71
4 files changed, 110 insertions, 1 deletions
diff --git a/x11-misc/xrmap/ChangeLog b/x11-misc/xrmap/ChangeLog
index cfb84b1b74cb..4e64172d61e6 100644
--- a/x11-misc/xrmap/ChangeLog
+++ b/x11-misc/xrmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xrmap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/ChangeLog,v 1.16 2010/02/06 21:14:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/ChangeLog,v 1.17 2010/05/28 21:10:03 hwoarang Exp $
+
+*xrmap-2.33 (28 May 2010)
+
+ 28 May 2010; Markos Chandras <hwoarang@gentoo.org> +xrmap-2.33.ebuild:
+ Version bump. Fixes bug #309661
06 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> xrmap-2.32.ebuild,
+files/xrmap-2.32-asneeded.patch:
diff --git a/x11-misc/xrmap/files/xrmap-2.33-Makefile.kit.patch b/x11-misc/xrmap/files/xrmap-2.33-Makefile.kit.patch
new file mode 100644
index 000000000000..9cf26c7551cb
--- /dev/null
+++ b/x11-misc/xrmap/files/xrmap-2.33-Makefile.kit.patch
@@ -0,0 +1,20 @@
+Index: xrmap-2.33/editkit/Makefile.kit
+===================================================================
+--- xrmap-2.33.orig/editkit/Makefile.kit
++++ xrmap-2.33/editkit/Makefile.kit
+@@ -15,13 +15,14 @@
+
+ SHAREDIR=/usr/share/editkit
+
+-CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\""
++CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DTHREED -DGREEK -DJUSTIFY -DSHAREDIR="\"$(SHAREDIR)\"" -DSHAREDIR="\"$(SHARE_DIR)\""
+
+ #CFLAGS = -O2 -fomit-frame-pointer -pipe -Wall -DMINIMAL -DTWOBUTN -DVERTCURS -DTLL
+
+ #CFLAGS = -g -pipe
+
+ TLIBS = -L/usr/lib -ltermcap
++TLIBS = -L/usr/lib -lcurses
+ XLIBS = -L/usr/X11R6/lib -lX11
+
+ # Use this for solaris
diff --git a/x11-misc/xrmap/files/xrmap-2.33-as-needed.patch b/x11-misc/xrmap/files/xrmap-2.33-as-needed.patch
new file mode 100644
index 000000000000..82f29f5e3e8a
--- /dev/null
+++ b/x11-misc/xrmap/files/xrmap-2.33-as-needed.patch
@@ -0,0 +1,13 @@
+Index: xrmap-2.33/Makefile.noimake
+===================================================================
+--- xrmap-2.33.orig/Makefile.noimake
++++ xrmap-2.33/Makefile.noimake
+@@ -20,7 +20,7 @@ LDOPTIONS=-O6 -g -Wall -lXpm -lX11 -ljp
+ ## LDOPTIONS=-O6 -g -Wall libxpm/libXpm.a -lX11 -lz -lm -L/usr/X11R6/lib
+
+ all: explorer.o image.o xrmap.o
+- gcc $(LDOPTIONS) -o xrmap explorer.o image.o xrmap.o
++ gcc -o xrmap explorer.o image.o xrmap.o $(LDOPTIONS)
+ cd editkit ; make -f Makefile.kit DESTDIR=$(DESTDIR)
+ cd earthview ; make DESTDIR=$(DESTDIR)
+ @cat EXTRADATA
diff --git a/x11-misc/xrmap/xrmap-2.33.ebuild b/x11-misc/xrmap/xrmap-2.33.ebuild
new file mode 100644
index 000000000000..29fc42dec2e0
--- /dev/null
+++ b/x11-misc/xrmap/xrmap-2.33.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xrmap/xrmap-2.33.ebuild,v 1.1 2010/05/28 21:10:03 hwoarang Exp $
+
+inherit eutils
+
+DESCRIPTION="a X client for generating images of the Earth and manipulating the CIA World data bank"
+HOMEPAGE="http://frmas.free.fr/li_1.htm#_Xrmap_"
+FULL_DIST="2.10"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${PN}-${FULL_DIST}.tgz
+ ftp://ftp.ac-grenoble.fr/ge/geosciences/${PN}/${P}.tar.bz2
+ ftp://ftp.ac-grenoble.fr/ge/geosciences/CIA_WDB2.jpd.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="zlib"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-misc/imake
+ x11-proto/xproto
+ media-gfx/imagemagick
+ app-text/gv
+ sys-apps/less
+ >=sys-apps/sed-4
+ zlib? ( sys-libs/zlib )"
+
+src_unpack() {
+ unpack ${A}
+ rm -rf "${S}"
+ mv "${WORKDIR}"/${PN}-${FULL_DIST} "${S}"
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-Makefile.kit.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
+ cd "${S}"/editkit && xmkmf || die
+}
+
+src_compile() {
+ use zlib || sed -i 's/-DZLIB\|-lz//g' Makefile.noimake || die
+
+ sed -e 's,^\(X11DIR=\).*,\1/usr/,g' \
+ -e 's,^\(EDITOR=\).*,\1less,g' \
+ -e 's,^\(SHAREDIR=\).*,\1/usr/share/xrmap,g' \
+ -e 's,^\(CCOPTIONS=\)-O6 -g,\1${CFLAGS},g' Makefile.noimake > Makefile || die
+
+ sed -i -e 's,^\(#define RCFILE \)SHAREDIR\",\1\"/etc/xrmap,g' \
+ -e 's,^\(#define SHAREDIR \"/usr/share/\),\1x,g' xrmap.h || die
+ emake || die
+ cd tools
+ emake || die
+ cd jpd2else
+ sed -i 's,^\(#define DEFAULT_JPD_FILE \"/usr/share/\),\1x,g' jpd2else.c || die
+ emake || die
+ cd ../cbd2else
+ emake || die
+}
+
+src_install() {
+ dobin xrmap tools/preproc tools/jpd2else/jpd2else tools/cbd2else/cbd2else || die
+ dodir /usr/share/${PN}/ || die
+ dodir /etc/xrmap || die
+ cp -r {i18n,Locations,factbook,anthems,flags,hymns,pixmaps} "${D}"/usr/share/${PN}/ || die
+ cp Xrmaprc "${D}"/etc/xrmap || die
+ cp "${WORKDIR}"/CIA_WDB2.jpd "${D}"/usr/share/${PN}/ || die
+ dodoc CHANGES README TODO WARNING tools/cbd2else/README.cbd tools/jpd2else/README.jpd tools/rez2else/README.rez || die
+
+ cd "${S}"
+ newman xrmap.man xrmap.1 || die "newman failed"
+}