summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-08 18:52:53 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-08 18:52:53 +0000
commit540a64de5b6e68b0247a95df22135bcd7cc109d0 (patch)
tree2ed2a81504569e0a21065cef54719e686d863df7 /x11-misc
parentLinux patch 3.0.1 (diff)
downloadgentoo-2-540a64de5b6e68b0247a95df22135bcd7cc109d0.tar.gz
gentoo-2-540a64de5b6e68b0247a95df22135bcd7cc109d0.tar.bz2
gentoo-2-540a64de5b6e68b0247a95df22135bcd7cc109d0.zip
Version bump
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/parcellite/ChangeLog8
-rw-r--r--x11-misc/parcellite/parcellite-1.0.2_rc3.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/parcellite/ChangeLog b/x11-misc/parcellite/ChangeLog
index 9d0c4696c8a8..b5d413ba5498 100644
--- a/x11-misc/parcellite/ChangeLog
+++ b/x11-misc/parcellite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/parcellite
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.13 2011/04/09 07:40:29 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/ChangeLog,v 1.14 2011/08/08 18:52:53 hwoarang Exp $
+
+*parcellite-1.0.2_rc3 (08 Aug 2011)
+
+ 08 Aug 2011; Markos Chandras <hwoarang@gentoo.org>
+ +parcellite-1.0.2_rc3.ebuild:
+ Version bump
*parcellite-1.0.2_rc2 (09 Apr 2011)
diff --git a/x11-misc/parcellite/parcellite-1.0.2_rc3.ebuild b/x11-misc/parcellite/parcellite-1.0.2_rc3.ebuild
new file mode 100644
index 000000000000..5589b4ec68e8
--- /dev/null
+++ b/x11-misc/parcellite/parcellite-1.0.2_rc3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/parcellite/parcellite-1.0.2_rc3.ebuild,v 1.1 2011/08/08 18:52:53 hwoarang Exp $
+
+EAPI=4
+inherit fdo-mime autotools
+
+MY_PV="${PV/_/}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A lightweight GTK+ based clipboard manager."
+HOMEPAGE="http://parcellite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.14:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext
+ dev-util/intltool )"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}