summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2008-08-21 22:38:37 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2008-08-21 22:38:37 +0000
commit2a49011c293b3447c3c3d120b5d3f0fd3de546a1 (patch)
tree9958b4d3f7da760e41f701e7ffeda1d497851dab /x11-misc
parentadd x11-terms to completed list (diff)
downloadgentoo-2-2a49011c293b3447c3c3d120b5d3f0fd3de546a1.tar.gz
gentoo-2-2a49011c293b3447c3c3d120b5d3f0fd3de546a1.tar.bz2
gentoo-2-2a49011c293b3447c3c3d120b5d3f0fd3de546a1.zip
If build with USE=cairo, check that x11-libs/cairo is built with USE=X. Bug #225149
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r4 x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/matchbox-keyboard/ChangeLog7
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild12
2 files changed, 16 insertions, 3 deletions
diff --git a/x11-misc/matchbox-keyboard/ChangeLog b/x11-misc/matchbox-keyboard/ChangeLog
index 2808ea8cfc8b..6c0c42e82792 100644
--- a/x11-misc/matchbox-keyboard/ChangeLog
+++ b/x11-misc/matchbox-keyboard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/matchbox-keyboard
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/ChangeLog,v 1.6 2008/07/17 17:15:11 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/ChangeLog,v 1.7 2008/08/21 22:38:37 yvasilev Exp $
+
+ 21 Aug 2008; Yuri Vasilevski <yvasilev@gentoo.org>
+ matchbox-keyboard-0.1.ebuild:
+ If build with USE=cairo, check that x11-libs/cairo is built with USE=X.
+ Bug #225149
17 Jul 2008; Yuri Vasilevski <yvasilev@gentoo.org>
matchbox-keyboard-0.1.ebuild:
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
index 7a46e9100571..bc9f6d953351 100644
--- a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 2006-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild,v 1.6 2008/07/17 17:15:11 yvasilev Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1.ebuild,v 1.7 2008/08/21 22:38:37 yvasilev Exp $
-inherit versionator
+inherit versionator eutils
DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard."
HOMEPAGE="http://matchbox-project.org/"
@@ -17,6 +17,14 @@ DEPEND="x11-libs/libfakekey
cairo? ( x11-libs/cairo )
!cairo? ( x11-libs/libXft )"
+pkg_setup() {
+ if use cairo && ! built_with_use x11-libs/cairo X ; then
+ eerror "In order to install ${PN} with cairo support you"
+ eerror "need to reinstall x11-libs/cairo with USE='X'."
+ die "x11-libs/cairo built without USE='X'"
+ fi
+}
+
src_compile() {
econf $(use_enable debug) \
$(use_enable cairo) \