summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPrzemyslaw Maciag <troll@gentoo.org>2007-03-14 01:18:50 +0000
committerPrzemyslaw Maciag <troll@gentoo.org>2007-03-14 01:18:50 +0000
commitcf436e78c8a0bcda3b2d8ad52b368f6c71276373 (patch)
treee5798408958c777a63b03542c26cdd007934e79e /x11-misc/xbindkeys
parentwhich -> type -P fix (diff)
downloadgentoo-2-cf436e78c8a0bcda3b2d8ad52b368f6c71276373.tar.gz
gentoo-2-cf436e78c8a0bcda3b2d8ad52b368f6c71276373.tar.bz2
gentoo-2-cf436e78c8a0bcda3b2d8ad52b368f6c71276373.zip
Add check for deprecated guile USE flag, in order to compile with recent guile versions (#163650)
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-misc/xbindkeys')
-rw-r--r--x11-misc/xbindkeys/ChangeLog7
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild29
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild32
3 files changed, 42 insertions, 26 deletions
diff --git a/x11-misc/xbindkeys/ChangeLog b/x11-misc/xbindkeys/ChangeLog
index daf7cd360dff..1747fbebfc33 100644
--- a/x11-misc/xbindkeys/ChangeLog
+++ b/x11-misc/xbindkeys/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xbindkeys
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.47 2007/02/18 20:55:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.48 2007/03/14 01:18:50 troll Exp $
+
+ 14 Mar 2007; Przemysław Maciąg <troll@gentoo.org>
+ xbindkeys-1.7.3.ebuild, xbindkeys-1.8.0.ebuild:
+ Add check for compilation with guile-1.8 (see #163650). Thx to
+ degrenier@easyconnect.fr
18 Feb 2007; Fabian Groffen <grobian@gentoo.org> xbindkeys-1.7.3.ebuild,
xbindkeys-1.8.0.ebuild:
diff --git a/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild b/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild
index 18aa95945a03..0ccaa0eaca5d 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild
@@ -1,12 +1,15 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild,v 1.9 2007/02/18 20:55:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.7.3.ebuild,v 1.10 2007/03/14 01:18:50 troll Exp $
+
+inherit eutils
IUSE="guile tk"
DESCRIPTION="Tool for launching commands on keystrokes"
SRC_URI="http://hocwp.free.fr/xbindkeys/${P}.tar.gz"
HOMEPAGE="http://hocwp.free.fr/xbindkeys/"
+
LICENSE="GPL-2"
KEYWORDS="amd64 ppc ppc64 sparc x86"
SLOT="0"
@@ -14,26 +17,28 @@ SLOT="0"
RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
guile? ( dev-scheme/guile )
tk? ( dev-lang/tk )"
-
DEPEND="${RDEPEND}
|| ( x11-proto/xproto virtual/x11 )"
-src_compile() {
+pkg_setup() {
+ if use guile && has_version ">=dev-scheme/guile-1.8" \
+ && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
+ then
+ eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
+ eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
+ die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
+ fi
+}
+src_compile() {
local myconf
use tk || myconf="${myconf} --disable-tk"
use guile || myconf="${myconf} --disable-guile"
- econf ${myconf} || die
- emake DESTDIR=${D} || die
-
-
+ econf ${myconf} || die "configure failed"
+ emake DESTDIR=${D} || die "make failed"
}
src_install() {
-
- emake DESTDIR=${D} \
- BINDIR=/usr/bin install || die "Installation failed"
-
+ make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
}
-
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild
index f8e0920718a1..2504c01270b3 100644
--- a/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild
@@ -1,38 +1,44 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild,v 1.2 2007/02/18 20:55:58 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.0.ebuild,v 1.3 2007/03/14 01:18:50 troll Exp $
+
+inherit eutils
+
+IUSE="guile tk"
DESCRIPTION="Tool for launching commands on keystrokes"
SRC_URI="http://hocwp.free.fr/xbindkeys/${P}.tar.gz"
HOMEPAGE="http://hocwp.free.fr/xbindkeys/"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
SLOT="0"
-IUSE="guile tk"
-
RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
guile? ( dev-scheme/guile )
tk? ( dev-lang/tk )"
-
DEPEND="${RDEPEND}
|| ( x11-proto/xproto virtual/x11 )"
-src_compile() {
+pkg_setup() {
+ if use guile && has_version ">=dev-scheme/guile-1.8" \
+ && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
+ then
+ eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
+ eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
+ die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
+ fi
+}
+src_compile() {
local myconf
use tk || myconf="${myconf} --disable-tk"
use guile || myconf="${myconf} --disable-guile"
- econf ${myconf} || die
- emake DESTDIR=${D} || die
-
+ econf ${myconf} || die "configure failed"
+ emake DESTDIR=${D} || die "make failed"
}
src_install() {
-
- emake DESTDIR=${D} \
- BINDIR=/usr/bin install || die "Installation failed"
-
+ make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
}