summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-02-08 18:11:28 +0000
committerJeroen Roovers <jer@gentoo.org>2010-02-08 18:11:28 +0000
commit6ff7fb972e6a0286a04a6bb1c2488e25f199bf87 (patch)
tree0df2c07e3ad79d6defca88511f3a69966a0cf00b /x11-misc/xbindkeys
parentRemove dev-perl/Devel-Size-Report (#300011) (diff)
downloadgentoo-2-6ff7fb972e6a0286a04a6bb1c2488e25f199bf87.tar.gz
gentoo-2-6ff7fb972e6a0286a04a6bb1c2488e25f199bf87.tar.bz2
gentoo-2-6ff7fb972e6a0286a04a6bb1c2488e25f199bf87.zip
Version bump thanks to Tim Harder (bug #246035).
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'x11-misc/xbindkeys')
-rw-r--r--x11-misc/xbindkeys/ChangeLog9
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/x11-misc/xbindkeys/ChangeLog b/x11-misc/xbindkeys/ChangeLog
index 1d157e0e6b54..168bdfffbfc4 100644
--- a/x11-misc/xbindkeys/ChangeLog
+++ b/x11-misc/xbindkeys/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xbindkeys
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.50 2007/08/06 19:36:39 uberlord Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/ChangeLog,v 1.51 2010/02/08 18:11:28 jer Exp $
+
+*xbindkeys-1.8.3 (08 Feb 2010)
+
+ 08 Feb 2010; Jeroen Roovers <jer@gentoo.org> +xbindkeys-1.8.3.ebuild:
+ Version bump thanks to Tim Harder (bug #246035).
06 Aug 2007; Roy Marples <uberlord@gentoo.org> xbindkeys-1.8.0.ebuild:
Keyworded ~x86-fbsd, #141142 thanks to Robert Annessi
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
new file mode 100644
index 000000000000..bc66e8278a3f
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xbindkeys/xbindkeys-1.8.3.ebuild,v 1.1 2010/02/08 18:11:28 jer Exp $
+
+inherit eutils
+
+IUSE="guile tk"
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="http://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+
+RDEPEND="x11-libs/libX11
+ guile? ( dev-scheme/guile )
+ tk? ( dev-lang/tk )"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+pkg_setup() {
+ if use guile && has_version ">=dev-scheme/guile-1.8" \
+ && ! built_with_use ">=dev-scheme/guile-1.8" deprecated
+ then
+ eerror "In order to compile xbindkeys with guile-1.8 or higher, you need"
+ eerror "to recompile dev-scheme/guile with the \"deprecated\" USE flag."
+ die "Please re-emerge dev-scheme/guile with USE=\"deprecated\"."
+ fi
+}
+
+src_compile() {
+ local myconf
+ use tk || myconf="${myconf} --disable-tk"
+ use guile || myconf="${myconf} --disable-guile"
+
+ econf ${myconf} || die "configure failed"
+ emake DESTDIR=${D} || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} BINDIR=/usr/bin install || die "make install failed"
+}