summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-06 14:01:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-06 14:01:55 +0000
commit434b406b984377bc4b516126b024c7e06f74ecb1 (patch)
treed83cdc2c4819cb9848256411b8d22d18f7e4305b /x11-misc/wdm
parentImport from perl-experimental for dev-perl/DBIx-Class (diff)
downloadgentoo-2-434b406b984377bc4b516126b024c7e06f74ecb1.tar.gz
gentoo-2-434b406b984377bc4b516126b024c7e06f74ecb1.tar.bz2
gentoo-2-434b406b984377bc4b516126b024c7e06f74ecb1.zip
Apply terminateServer patch from bug 290034.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/wdm')
-rw-r--r--x11-misc/wdm/ChangeLog8
-rw-r--r--x11-misc/wdm/files/wdm-1.28-terminateServer.patch12
-rw-r--r--x11-misc/wdm/wdm-1.28-r3.ebuild (renamed from x11-misc/wdm/wdm-1.28-r2.ebuild)27
3 files changed, 34 insertions, 13 deletions
diff --git a/x11-misc/wdm/ChangeLog b/x11-misc/wdm/ChangeLog
index 5ceac99d866c..f645b4cc79e9 100644
--- a/x11-misc/wdm/ChangeLog
+++ b/x11-misc/wdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wdm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/ChangeLog,v 1.38 2010/03/13 13:24:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/ChangeLog,v 1.39 2010/06/06 14:01:55 ssuominen Exp $
+
+*wdm-1.28-r3 (06 Jun 2010)
+
+ 06 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> +wdm-1.28-r3.ebuild,
+ +files/wdm-1.28-terminateServer.patch:
+ Apply terminateServer patch from bug 290034.
13 Mar 2010; Markos Chandras <hwoarang@gentoo.org> wdm-1.28-r1.ebuild,
wdm-1.28-r2.ebuild:
diff --git a/x11-misc/wdm/files/wdm-1.28-terminateServer.patch b/x11-misc/wdm/files/wdm-1.28-terminateServer.patch
new file mode 100644
index 000000000000..3e167bd818e5
--- /dev/null
+++ b/x11-misc/wdm/files/wdm-1.28-terminateServer.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/290034
+
+--- configs/wdm-config.in
++++ configs/wdm-config.in
+@@ -21,6 +21,7 @@
+ DisplayManager*session: @DMDIR@/Xsession
+ DisplayManager*authComplain: false
+ DisplayManager*wdmLogin: @exec_prefix@/bin/wdmLogin
++DisplayManager*terminateServer: true
+ !
+ ! display screen background--if not set or set to none, then the
+ ! background is not set by wdm.
diff --git a/x11-misc/wdm/wdm-1.28-r2.ebuild b/x11-misc/wdm/wdm-1.28-r3.ebuild
index f820a89c64c7..8dd1601491ef 100644
--- a/x11-misc/wdm/wdm-1.28-r2.ebuild
+++ b/x11-misc/wdm/wdm-1.28-r3.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.28-r2.ebuild,v 1.9 2010/03/13 13:24:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wdm/wdm-1.28-r3.ebuild,v 1.1 2010/06/06 14:01:55 ssuominen Exp $
-inherit pam
+EAPI=2
+inherit eutils pam
DESCRIPTION="WINGs Display Manager"
HOMEPAGE="http://voins.program.ru/wdm/"
@@ -13,29 +14,31 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="truetype pam selinux"
-RDEPEND=">=x11-wm/windowmaker-0.70.0
+COMMON_DEPEND=">=x11-wm/windowmaker-0.70.0
truetype? ( x11-libs/libXft )
x11-libs/libXmu
x11-libs/libXt
x11-libs/libXpm
pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
sys-devel/gettext"
-RDEPEND="${RDEPEND}
+RDEPEND="${COMMON_DEPEND}
pam? ( >=sys-auth/pambase-20080219.1 )"
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-terminateServer.patch
+}
+
+src_configure() {
econf \
--exec-prefix=/usr \
--with-wdmdir=/etc/X11/wdm \
- $(use_enable pam)\
- $(use_enable selinux) \
- || die "econf failed"
- emake || die "emake failed"
+ $(use_enable pam) \
+ $(use_enable selinux)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- rm -f "${D}/etc/pam.d/wdm"
+ emake DESTDIR="${D}" install || die
+ rm -f "${D}"/etc/pam.d/wdm
pamd_mimic system-local-login wdm auth account password session
}