summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2006-07-11 07:18:29 +0000
committerStuart Herbert <stuart@gentoo.org>2006-07-11 07:18:29 +0000
commit09c6c676789543e1c583c654f36bc6290b4ae3c2 (patch)
tree9d9d77beaa9dab171cec3243b4e4cd748c01c6d7 /x11-misc/vym/vym-1.8.0.ebuild
parentAdd the promised always-shared ffmpeg policy, need a version bump as sh does ... (diff)
downloadgentoo-2-09c6c676789543e1c583c654f36bc6290b4ae3c2.tar.gz
gentoo-2-09c6c676789543e1c583c654f36bc6290b4ae3c2.tar.bz2
gentoo-2-09c6c676789543e1c583c654f36bc6290b4ae3c2.zip
Version bump
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'x11-misc/vym/vym-1.8.0.ebuild')
-rw-r--r--x11-misc/vym/vym-1.8.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/vym/vym-1.8.0.ebuild b/x11-misc/vym/vym-1.8.0.ebuild
new file mode 100644
index 000000000000..55f11c08361e
--- /dev/null
+++ b/x11-misc/vym/vym-1.8.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/vym/vym-1.8.0.ebuild,v 1.1 2006/07/11 07:18:29 stuart Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="View Your Mind -- a mindmap tool"
+HOMEPAGE="http://www.insilmaril.de/vym/"
+SRC_URI="mirror://sourceforge/vym/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="$(qt_min_version 3.3.3)
+ dev-lang/perl"
+RDEPEND="${DEPEND}
+ || ( ( x11-libs/libX11
+ x11-libs/libXext )
+ virtual/x11 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # create the makefile
+ ${QTDIR}/bin/qmake -o Makefile vym.pro
+ # strip out the binary stripping support
+ epatch ${FILESDIR}/50_Makefile-1.8.0.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ # we don't build the pdf, because texi2pdf chokes on the .tex source
+ # atm
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+ return
+
+ dobin vym
+ dobin scripts/exportvym
+ dobin scripts/vym2html.sh
+ dobin scripts/vym2txt.sh
+
+ dodoc demos/liveform.vym
+ dodoc demos/time-management.vym
+ dodoc demos/todo.vym
+
+ insinto /usr/share/${PN}/styles
+ for x in `echo styles/*` ; do
+ doins $x
+ done
+}