summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-05-18 04:32:24 +0000
committerJeroen Roovers <jer@gentoo.org>2014-05-18 04:32:24 +0000
commit9e0370a6465a15aef95d26db528e9b435c31ffb7 (patch)
tree474189069a7ff001d21855e51525805ba39f0cad /x11-misc/treeline
parentVersion bump. (diff)
downloadgentoo-2-9e0370a6465a15aef95d26db528e9b435c31ffb7.tar.gz
gentoo-2-9e0370a6465a15aef95d26db528e9b435c31ffb7.tar.bz2
gentoo-2-9e0370a6465a15aef95d26db528e9b435c31ffb7.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc/treeline')
-rw-r--r--x11-misc/treeline/ChangeLog9
-rw-r--r--x11-misc/treeline/treeline-1.9.4.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/x11-misc/treeline/ChangeLog b/x11-misc/treeline/ChangeLog
index 5b1f89d670fa..1042270fac77 100644
--- a/x11-misc/treeline/ChangeLog
+++ b/x11-misc/treeline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/treeline
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.57 2013/09/05 19:44:50 mgorny Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.58 2014/05/18 04:32:24 jer Exp $
+
+*treeline-1.9.4 (18 May 2014)
+
+ 18 May 2014; Jeroen Roovers <jer@gentoo.org> +treeline-1.9.4.ebuild:
+ Version bump.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> treeline-1.4.1-r1.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/x11-misc/treeline/treeline-1.9.4.ebuild b/x11-misc/treeline/treeline-1.9.4.ebuild
new file mode 100644
index 000000000000..d03c79529f60
--- /dev/null
+++ b/x11-misc/treeline/treeline-1.9.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.9.4.ebuild,v 1.1 2014/05/18 04:32:24 jer Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_3 )
+PYTHON_REQ_USE="xml"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="TreeLine is a structured information storage program."
+HOMEPAGE="http://treeline.bellz.org/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/TreeLine"
+
+src_prepare() {
+ rm doc/LICENSE || die
+
+ python_export PYTHON_SITEDIR
+ sed -i "s;prefixDir, 'lib;'${PYTHON_SITEDIR};" install.py || die
+}
+
+src_install() {
+ "${EPYTHON}" install.py -x -p /usr/ -d /usr/share/doc/${PF} -b "${D}" || die
+}