summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-05-16 22:37:07 +0000
committerSamuli Suominen <drac@gentoo.org>2007-05-16 22:37:07 +0000
commit597f08dda6325d084e133187b4d0b9cf81e4f007 (patch)
treef3f64d5d09150aae387df52b52b78982a51143ad /x11-misc/treeline
parentprune unused version (diff)
downloadgentoo-2-597f08dda6325d084e133187b4d0b9cf81e4f007.tar.gz
gentoo-2-597f08dda6325d084e133187b4d0b9cf81e4f007.tar.bz2
gentoo-2-597f08dda6325d084e133187b4d0b9cf81e4f007.zip
Install files so that treeline finds them for bugs 177645 and 177652.
(Portage version: 2.1.2.7)
Diffstat (limited to 'x11-misc/treeline')
-rw-r--r--x11-misc/treeline/ChangeLog8
-rw-r--r--x11-misc/treeline/files/digest-treeline-1.0.1-r1 (renamed from x11-misc/treeline/files/digest-treeline-1.0.1)0
-rw-r--r--x11-misc/treeline/treeline-1.0.1-r1.ebuild56
-rw-r--r--x11-misc/treeline/treeline-1.0.1.ebuild59
4 files changed, 63 insertions, 60 deletions
diff --git a/x11-misc/treeline/ChangeLog b/x11-misc/treeline/ChangeLog
index b955cf7c5627..858ffc3cb8fd 100644
--- a/x11-misc/treeline/ChangeLog
+++ b/x11-misc/treeline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/treeline
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.28 2007/04/10 08:56:27 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/ChangeLog,v 1.29 2007/05/16 22:37:07 drac Exp $
+
+*treeline-1.0.1-r1 (16 May 2007)
+
+ 16 May 2007; Samuli Suominen <drac@gentoo.org> -treeline-1.0.1.ebuild,
+ +treeline-1.0.1-r1.ebuild:
+ Install files so that treeline finds them for bugs 177645 and 177652.
*treeline-1.0.1 (10 Apr 2007)
diff --git a/x11-misc/treeline/files/digest-treeline-1.0.1 b/x11-misc/treeline/files/digest-treeline-1.0.1-r1
index 0a49a362bcac..0a49a362bcac 100644
--- a/x11-misc/treeline/files/digest-treeline-1.0.1
+++ b/x11-misc/treeline/files/digest-treeline-1.0.1-r1
diff --git a/x11-misc/treeline/treeline-1.0.1-r1.ebuild b/x11-misc/treeline/treeline-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..ec88c24e1c2d
--- /dev/null
+++ b/x11-misc/treeline/treeline-1.0.1-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.0.1-r1.ebuild,v 1.1 2007/05/16 22:37:07 drac Exp $
+
+inherit python
+
+DESCRIPTION="TreeLine is a structured information storage program."
+HOMEPAGE="http://www.bellz.org/treeline"
+SRC_URI="http://www.bellz.org/${PN}/${P}.tar.gz
+ http://www.bellz.org/${PN}/${PN}-i18n-${PV}a.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="spell"
+
+DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
+ || ( dev-python/pyxml dev-libs/expat )
+ virtual/python dev-python/PyQt
+ =x11-libs/qt-3*"
+
+S="${WORKDIR}"/TreeLine
+
+# Before you go editing below read bugs 177652 and 177645
+# or you'll end up breaking it.
+
+src_compile() {
+ printf '#!/bin/sh\n\nexec python %s/treeline.py $*\n' \
+ /usr/share/treeline > ${S}/treeline
+ sed -i -e "s#\(helpFilePath = \)None#\1'/usr/share/treeline'#g" \
+ -e "s#\(iconPath = \)None#\1'/usr/share/treeline/icons'#g" \
+ ${S}/source/treeline.py || die
+ sed -i -e 's,translations,/usr/share/treeline/translations,' \
+ ${S}/source/treeline.py || die
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins source/*.py doc/*.html doc/*.png doc/*.trl
+
+ insinto /usr/share/${PN}/icons
+ doins icons/*.png
+
+ insinto /usr/share/${PN}/translations
+ doins translations/*.qm
+
+ dobin ${PN}
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/x11-misc/treeline/treeline-1.0.1.ebuild b/x11-misc/treeline/treeline-1.0.1.ebuild
deleted file mode 100644
index 95ed460c7e31..000000000000
--- a/x11-misc/treeline/treeline-1.0.1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/treeline/treeline-1.0.1.ebuild,v 1.1 2007/04/10 08:56:27 nelchael Exp $
-
-inherit python
-
-DESCRIPTION="TreeLine is a structured information storage program."
-HOMEPAGE="http://www.bellz.org/treeline/"
-
-SRC_URI="http://www.bellz.org/treeline/${P}.tar.gz
- http://www.bellz.org/treeline/${PN}-i18n-${PV}a.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~ppc ~x86"
-IUSE="spell"
-
-DEPEND="spell? ( || ( app-text/aspell app-text/ispell ) )
- || ( dev-python/pyxml dev-libs/expat )
- virtual/python dev-python/PyQt
- =x11-libs/qt-3*"
-
-S=${WORKDIR}/TreeLine
-
-src_compile() {
- printf '#!/bin/sh\n\nexec python %s/treeline.py $*\n' \
- /usr/lib/treeline > ${T}/treeline
- sed -i -e "s#\(helpFilePath = \)None#\1'/usr/lib/treeline'#g" \
- -e "s#\(iconPath = \)None#\1'/usr/share/icons/treeline'#g" \
- ${S}/source/treeline.py || die
- sed -i -e 's,translations,/usr/share/treeline/translations,' \
- ${S}/source/treeline.py || die
-}
-
-src_install() {
- dodir /usr/lib/treeline /usr/share/icons /usr/share/treeline/translations
-
- insinto /usr/lib/treeline
- doins ${S}/source/*.py ${S}/doc/README.html
-
- insinto /usr/share/icons/treeline
- doins ${S}/icons/*.png
-
- insinto /usr/share/treeline/translations
- doins ${S}/translations/*.qm
-
- dodoc ${S}/doc/LICENSE ${S}/doc/*.trl
- dohtml ${S}/doc/README.html
-
- dobin ${T}/treeline
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/lib/treeline
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/lib/treeline
-}