summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-08-21 21:18:50 +0000
committerMichał Górny <mgorny@gentoo.org>2011-08-21 21:18:50 +0000
commit7e520049b92c2a445b9148429f49120e191571c9 (patch)
tree2987fb4cadf412346de779594e21cbec7bc3d1d9 /x11-misc/tinynotify-send
parentIntroduce the first ebuild for libtinynotify-systemwide. (diff)
downloadgentoo-2-7e520049b92c2a445b9148429f49120e191571c9.tar.gz
gentoo-2-7e520049b92c2a445b9148429f49120e191571c9.tar.bz2
gentoo-2-7e520049b92c2a445b9148429f49120e191571c9.zip
Introduce the first ebuild for tinynotify-send.
(Portage version: 2.2.0_alpha51_p4/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/tinynotify-send')
-rw-r--r--x11-misc/tinynotify-send/ChangeLog10
-rw-r--r--x11-misc/tinynotify-send/metadata.xml19
-rw-r--r--x11-misc/tinynotify-send/tinynotify-send-0.2.ebuild38
3 files changed, 67 insertions, 0 deletions
diff --git a/x11-misc/tinynotify-send/ChangeLog b/x11-misc/tinynotify-send/ChangeLog
new file mode 100644
index 000000000000..647ce0dc3e53
--- /dev/null
+++ b/x11-misc/tinynotify-send/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-misc/tinynotify-send
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinynotify-send/ChangeLog,v 1.1 2011/08/21 21:18:50 mgorny Exp $
+
+*tinynotify-send-0.2 (21 Aug 2011)
+
+ 21 Aug 2011; Michał Górny <mgorny@gentoo.org> +tinynotify-send-0.2.ebuild,
+ +metadata.xml:
+ Introduce the first ebuild for tinynotify-send.
+
diff --git a/x11-misc/tinynotify-send/metadata.xml b/x11-misc/tinynotify-send/metadata.xml
new file mode 100644
index 000000000000..0198c1707014
--- /dev/null
+++ b/x11-misc/tinynotify-send/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name='symlink'>Symlink tinynotify-send to notify-send.</flag>
+ </use>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>http://bugs.gentoo.org/enter_bug.cgi?product=Gentoo%20Linux&amp;component=Applications&amp;short_desc=x11-misc/tinynotify-send:%20</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/tinynotify-send/tinynotify-send-0.2.ebuild b/x11-misc/tinynotify-send/tinynotify-send-0.2.ebuild
new file mode 100644
index 000000000000..586162fdc07a
--- /dev/null
+++ b/x11-misc/tinynotify-send/tinynotify-send-0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tinynotify-send/tinynotify-send-0.2.ebuild,v 1.1 2011/08/21 21:18:50 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="A notification sending utility (using libtinynotify)"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="symlink"
+
+RDEPEND="x11-libs/libtinynotify
+ x11-libs/libtinynotify-cli
+ symlink? ( !x11-libs/libnotify )"
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+
+src_configure() {
+ myeconfargs=(
+ --enable-regular
+ --disable-system-wide
+ --with-system-wide-exec=/usr/bin/sw-notify-send
+ )
+
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ use symlink && dosym tinynotify-send /usr/bin/notify-send
+}