summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-08-23 03:09:32 +0000
committerJeroen Roovers <jer@gentoo.org>2012-08-23 03:09:32 +0000
commit0269b104119d0649df3f61bc0260e039c0425694 (patch)
treec06f146536409306fcbde75a668902853f239a2b /x11-misc/tabbed
parentoops, inverted day and month... (diff)
downloadgentoo-2-0269b104119d0649df3f61bc0260e039c0425694.tar.gz
gentoo-2-0269b104119d0649df3f61bc0260e039c0425694.tar.bz2
gentoo-2-0269b104119d0649df3f61bc0260e039c0425694.zip
Version bump.
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/tabbed')
-rw-r--r--x11-misc/tabbed/ChangeLog7
-rw-r--r--x11-misc/tabbed/tabbed-0.4.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-misc/tabbed/ChangeLog b/x11-misc/tabbed/ChangeLog
index 21b4e88afe59..738ba9a8051d 100644
--- a/x11-misc/tabbed/ChangeLog
+++ b/x11-misc/tabbed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/tabbed
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/ChangeLog,v 1.2 2012/07/18 17:11:43 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/ChangeLog,v 1.3 2012/08/23 03:09:32 jer Exp $
+
+*tabbed-0.4.1 (23 Aug 2012)
+
+ 23 Aug 2012; Jeroen Roovers <jer@gentoo.org> +tabbed-0.4.1.ebuild:
+ Version bump.
*tabbed-0.4 (18 Jul 2012)
diff --git a/x11-misc/tabbed/tabbed-0.4.1.ebuild b/x11-misc/tabbed/tabbed-0.4.1.ebuild
new file mode 100644
index 000000000000..62e3986c0762
--- /dev/null
+++ b/x11-misc/tabbed/tabbed-0.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/tabbed/tabbed-0.4.1.ebuild,v 1.1 2012/08/23 03:09:32 jer Exp $
+
+EAPI="3"
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple generic tabbed fronted to xembed aware applications"
+HOMEPAGE="http://tools.suckless.org/tabbed"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="
+ x11-proto/xproto
+ ${RDEPEND}
+"
+
+src_prepare() {
+ sed config.mk \
+ -e '/^CC/d' \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall $(INCS) $(CPPFLAGS)|g' \
+ -e 's|^LDFLAGS.*|LDFLAGS += $(LIBS)|g' \
+ -e 's|^LIBS.*|LIBS = -lX11|g' \
+ -e 's|{|(|g;s|}|)|g' \
+ -i || die
+
+ sed Makefile \
+ -e 's|{|(|g;s|}|)|g' \
+ -e '/^[[:space:]]*@echo/d' \
+ -e 's|^ @| |g' \
+ -i || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake compile failed"
+}
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ save_config config.h
+}