summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-10 10:36:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-10 10:36:26 +0000
commit820767b1503841e723d97dc8a8673c972f649918 (patch)
treed6afb7f99e421c28d4ca4344b7131e6387c65e44 /x11-misc/shutter
parentx86 stable wrt bug #339953 (diff)
downloadgentoo-2-820767b1503841e723d97dc8a8673c972f649918.tar.gz
gentoo-2-820767b1503841e723d97dc8a8673c972f649918.tar.bz2
gentoo-2-820767b1503841e723d97dc8a8673c972f649918.zip
Version bump
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/shutter')
-rw-r--r--x11-misc/shutter/ChangeLog8
-rw-r--r--x11-misc/shutter/files/0.86.4-disable-goocanvas.patch21
-rw-r--r--x11-misc/shutter/shutter-0.86.4.ebuild59
3 files changed, 87 insertions, 1 deletions
diff --git a/x11-misc/shutter/ChangeLog b/x11-misc/shutter/ChangeLog
index 152fdf0c2c33..16a9c97bf8d0 100644
--- a/x11-misc/shutter/ChangeLog
+++ b/x11-misc/shutter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/shutter
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/ChangeLog,v 1.13 2010/07/14 13:10:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/ChangeLog,v 1.14 2010/10/10 10:36:26 hwoarang Exp $
+
+*shutter-0.86.4 (10 Oct 2010)
+
+ 10 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
+ +files/0.86.4-disable-goocanvas.patch, +shutter-0.86.4.ebuild:
+ Version bump
14 Jul 2010; Markos Chandras <hwoarang@gentoo.org> -shutter-0.85.ebuild,
-shutter-0.85.1-r1.ebuild, -shutter-0.86.1.ebuild:
diff --git a/x11-misc/shutter/files/0.86.4-disable-goocanvas.patch b/x11-misc/shutter/files/0.86.4-disable-goocanvas.patch
new file mode 100644
index 000000000000..aea2e67f1714
--- /dev/null
+++ b/x11-misc/shutter/files/0.86.4-disable-goocanvas.patch
@@ -0,0 +1,21 @@
+Index: shutter-0.86.4/bin/shutter
+===================================================================
+--- shutter-0.86.4.orig/bin/shutter
++++ shutter-0.86.4/bin/shutter
+@@ -8350,14 +8350,9 @@ sub fct_init_depend {
+ $nautilus_sendto = FALSE;
+ }
+
+- #goocanvas
+- eval { require Goo::Canvas };
+- if ($@) {
+- warn "WARNING: Goo::Canvas/libgoocanvas is missing --> drawing tool will be disabled!\n\n";
+- $goocanvas = FALSE;
+- }
++ $goocanvas = FALSE;
+
+- eval { require Net::DBus::GLib };
++ eval { require Net::DBus::GLib };
+ if ($@) {
+ warn "WARNING: Net::DBus::GLib is missing --> Ubuntu One support will be disabled!\n\n";
+ $ubuntuone = FALSE;
diff --git a/x11-misc/shutter/shutter-0.86.4.ebuild b/x11-misc/shutter/shutter-0.86.4.ebuild
new file mode 100644
index 000000000000..a4e4786c9f58
--- /dev/null
+++ b/x11-misc/shutter/shutter-0.86.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/shutter-0.86.4.ebuild,v 1.1 2010/10/10 10:36:26 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Feature-rich screenshot program"
+HOMEPAGE="http://shutter-project.org/"
+SRC_URI="http://shutter-project.org/wp-content/uploads/releases/tars/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="drawing webphoto"
+
+RDEPEND="dev-lang/perl
+ dev-perl/gnome2-gconf
+ drawing? ( dev-perl/Goo-Canvas )
+ webphoto? ( gnome-extra/gnome-web-photo )
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ dev-perl/libxml-perl
+ dev-perl/gnome2-wnck
+ dev-perl/gnome2-canvas
+ dev-perl/gnome2-perl
+ dev-perl/Gtk2-ImageView
+ dev-perl/File-DesktopEntry
+ dev-perl/File-HomeDir
+ dev-perl/File-Which
+ dev-perl/File-Copy-Recursive
+ dev-perl/File-MimeInfo
+ dev-perl/Locale-gettext
+ dev-perl/Net-DBus
+ dev-perl/Proc-Simple
+ dev-perl/Proc-ProcessTable
+ dev-perl/Sort-Naturally
+ dev-perl/WWW-Mechanize
+ dev-perl/X11-Protocol
+ dev-perl/XML-Simple
+ dev-perl/libwww-perl"
+
+src_prepare() {
+ use webphoto || epatch "${FILESDIR}"/disable_webphoto.patch
+ use drawing || epatch "${FILESDIR}"/${PV}-disable-goocanvas.patch
+}
+
+src_install() {
+ dobin bin/${PN} || die "dobin failed"
+ insinto /usr/share/${PN}
+ doins -r share/${PN}/* || die "doins failed"
+ dodoc README || die "dodoc failed"
+ domenu share/applications/${PN}.desktop
+ doman share/man/man1/${PN}.1.gz || die "doman failed"
+ doicon share/pixmaps/${PN}.png
+ doins -r share/locale || die "doins failed"
+ find "${D}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod 755 {} \; \
+ || die "failed to make plugins executables"
+}