summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2012-07-03 00:43:47 +0000
committerTristan Heaven <tristan@gentoo.org>2012-07-03 00:43:47 +0000
commit7ccd5e8a0349a8e1317a982c54d6993c11e3a387 (patch)
tree27f768617c68e95da902fe75ec49e6a9acae9fc7 /x11-misc/revelation
parentmarked x86 per bug 424533 (diff)
downloadgentoo-2-7ccd5e8a0349a8e1317a982c54d6993c11e3a387.tar.gz
gentoo-2-7ccd5e8a0349a8e1317a982c54d6993c11e3a387.tar.bz2
gentoo-2-7ccd5e8a0349a8e1317a982c54d6993c11e3a387.zip
Version bump addressing file format security issue, bug #421571
(Portage version: 2.2.0_alpha114/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/revelation')
-rw-r--r--x11-misc/revelation/ChangeLog7
-rw-r--r--x11-misc/revelation/revelation-0.4.14.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/x11-misc/revelation/ChangeLog b/x11-misc/revelation/ChangeLog
index e4d326dad18c..ad1888bc49e2 100644
--- a/x11-misc/revelation/ChangeLog
+++ b/x11-misc/revelation/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/revelation
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.24 2012/05/29 11:32:46 tristan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/ChangeLog,v 1.25 2012/07/03 00:43:47 tristan Exp $
+
+*revelation-0.4.14 (03 Jul 2012)
+
+ 03 Jul 2012; Tristan Heaven <tristan@gentoo.org> +revelation-0.4.14.ebuild:
+ Version bump addressing file format security issue, bug #421571
29 May 2012; Tristan Heaven <tristan@gentoo.org> revelation-0.4.13.ebuild:
Fix dependencies as pointed out by Mikel Olasagasti
diff --git a/x11-misc/revelation/revelation-0.4.14.ebuild b/x11-misc/revelation/revelation-0.4.14.ebuild
new file mode 100644
index 000000000000..5ed4dc33b7d4
--- /dev/null
+++ b/x11-misc/revelation/revelation-0.4.14.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/revelation/revelation-0.4.14.ebuild,v 1.1 2012/07/03 00:43:47 tristan Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+GCONF_DEBUG="no"
+
+inherit python gnome2
+
+DESCRIPTION="A password manager for GNOME"
+HOMEPAGE="http://revelation.olasagasti.info/"
+SRC_URI="https://bitbucket.org/erikg/revelation/downloads/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="applet"
+RESTRICT="test"
+
+RDEPEND="dev-python/pygtk
+ dev-python/pycrypto
+ dev-python/gconf-python
+ dev-python/libgnome-python
+ sys-libs/cracklib[python]
+ applet? (
+ dev-python/gnome-applets-python
+ dev-python/libbonobo-python
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+ gnome2_src_prepare
+ echo -n > py-compile
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-desktop-update \
+ --disable-mime-update \
+ $(use_with applet)
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ gnome2_src_install
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup ${PN}
+}