summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-04-17 10:39:59 +0000
committerTorsten Veller <tove@gentoo.org>2008-04-17 10:39:59 +0000
commitd80cc21f0128d5cba389e678f9d8e35176354bfe (patch)
tree2d329aefe174ef1385865c35f4925bc3ba7e745a /x11-misc/remind
parentVersion bump (diff)
downloadgentoo-2-d80cc21f0128d5cba389e678f9d8e35176354bfe.tar.gz
gentoo-2-d80cc21f0128d5cba389e678f9d8e35176354bfe.tar.bz2
gentoo-2-d80cc21f0128d5cba389e678f9d8e35176354bfe.zip
Version bump. Cleaning.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'x11-misc/remind')
-rw-r--r--x11-misc/remind/ChangeLog8
-rw-r--r--x11-misc/remind/files/03.00.24/01-optional-filename.patch100
-rw-r--r--x11-misc/remind/files/03.00.24/03-broken-postscript.patch11
-rw-r--r--x11-misc/remind/files/03.00.24/03-tkremind-no-newlines.patch23
-rw-r--r--x11-misc/remind/files/03.00.24/04-rem-cmd.patch12
-rw-r--r--x11-misc/remind/remind-03.00.24.ebuild32
-rw-r--r--x11-misc/remind/remind-03.01.05.ebuild (renamed from x11-misc/remind/remind-03.01.03.ebuild)14
7 files changed, 10 insertions, 190 deletions
diff --git a/x11-misc/remind/ChangeLog b/x11-misc/remind/ChangeLog
index 5610f06a46b8..7f440f142fb9 100644
--- a/x11-misc/remind/ChangeLog
+++ b/x11-misc/remind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/remind
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/ChangeLog,v 1.28 2008/03/30 11:13:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/ChangeLog,v 1.29 2008/04/17 10:39:58 tove Exp $
+
+*remind-03.01.05 (17 Apr 2008)
+
+ 17 Apr 2008; Torsten Veller <tove@gentoo.org> -remind-03.00.24.ebuild,
+ -remind-03.01.03.ebuild, +remind-03.01.05.ebuild:
+ Version bump. Cleaning
30 Mar 2008; Raúl Porcel <armin76@gentoo.org> remind-03.01.04.ebuild:
sparc stable wrt #214361
diff --git a/x11-misc/remind/files/03.00.24/01-optional-filename.patch b/x11-misc/remind/files/03.00.24/01-optional-filename.patch
deleted file mode 100644
index 84a64a817f8b..000000000000
--- a/x11-misc/remind/files/03.00.24/01-optional-filename.patch
+++ /dev/null
@@ -1,100 +0,0 @@
-diff -Naur remind-03.00.24/man/remind.1 remind/man/remind.1
---- remind-03.00.24/man/remind.1 2005-09-30 05:33:53.000000000 +0200
-+++ remind/man/remind.1 2006-01-15 15:40:42.000000000 +0100
-@@ -4,7 +4,7 @@
- .SH NAME
- remind \- a sophisticated reminder service
- .SH SYNOPSIS
--.B remind [\fIoptions\fR] \fIfilename\fR [\fIdate\fR] [\fI*rep\fR] [\fItime\fR]
-+.B remind [\fIoptions\fR] [\fIfilename\fR [\fIdate\fR] [\fI*rep\fR] [\fItime\fR] ]
- .SH DESCRIPTION
- \fBRemind\fR reads the supplied \fIfilename\fR and executes the commands
- found in it. The commands are used to issue reminders and alarms. Each
-@@ -13,7 +13,9 @@
- .PP
- If \fIfilename\fR is specified as a single dash '-', then \fBRemind\fR
- takes its input from standard input. This also implicitly enables
--the \fB\-o\fR option, described below.
-+the \fB\-o\fR option, described below. If no filename is given, remind uses
-+\fI~/.reminders\fR or the content of the DOT_REMINDERS environment
-+variable.
- .SH OPTIONS
- \fBRemind\fR has a slew of options. If you're new to the program,
- ignore them for now and skip to the section "Reminder Files".
-diff -Naur remind-03.00.24/src/init.c remind/src/init.c
---- remind-03.00.24/src/init.c 2005-09-30 05:29:32.000000000 +0200
-+++ remind/src/init.c 2006-01-15 15:40:42.000000000 +0100
-@@ -32,6 +32,8 @@
- #include "version.h"
- #include "globals.h"
-
-+#define DOT_REMINDERS ".reminders"
-+
- /***************************************************************
- *
- * Command line options recognized:
-@@ -87,6 +89,30 @@
-
- /***************************************************************/
- /* */
-+/* DefaultReminders */
-+/* */
-+/* Detect a default reminder file */
-+/* */
-+/***************************************************************/
-+
-+char* DefaultReminders()
-+{
-+ char *dot_reminders;
-+ char *home;
-+ size_t len;
-+ if((dot_reminders=getenv("DOT_REMINDERS")))
-+ return dot_reminders;
-+ else if((home=getenv("HOME"))) {
-+ len = strlen(home) + strlen(DOT_REMINDERS) + 2;
-+ dot_reminders = (char*)malloc(len);
-+ snprintf(dot_reminders, len, "%s/%s", home, DOT_REMINDERS);
-+ return dot_reminders;
-+ }
-+ else return DOT_REMINDERS;
-+}
-+
-+/***************************************************************/
-+/* */
- /* InitRemind */
- /* */
- /* Initialize the system - called only once at beginning! */
-@@ -348,11 +374,8 @@
- }
-
- /* Get the filename. */
-- if (i >= argc) {
-- Usage();
-- exit(1);
-- }
-- InitialFile = argv[i++];
-+ if (i >= argc) InitialFile = DefaultReminders();
-+ else InitialFile = argv[i++];
-
- /* Get the date, if any */
- if (i < argc) {
-@@ -448,7 +471,7 @@
- #ifdef BETA
- fprintf(ErrFp, ">>>> BETA VERSION <<<<\n");
- #endif
-- fprintf(ErrFp, "Usage: remind [options] filename [date] [time] [*rep]\n");
-+ fprintf(ErrFp, "Usage: remind [options] [filename [date] [time] [*rep] ]\n");
- fprintf(ErrFp, "Options:\n");
- fprintf(ErrFp, " -n Output next occurrence of reminders in simple format\n");
- fprintf(ErrFp, " -r Disable RUN directives\n");
-diff -Naur remind-03.00.24/src/protos.h remind/src/protos.h
---- remind-03.00.24/src/protos.h 2005-09-30 05:29:32.000000000 +0200
-+++ remind/src/protos.h 2006-01-15 15:42:11.000000000 +0100
-@@ -45,6 +45,7 @@
- int SetAccessDate (char *fname, int jul);
- int TopLevel (void);
- int CallFunc (Operator *f, int nargs);
-+char *DefaultReminders (void);
- void InitRemind (int argc, char *argv[]);
- void Usage (void);
- int main (int argc, char *argv[]);
diff --git a/x11-misc/remind/files/03.00.24/03-broken-postscript.patch b/x11-misc/remind/files/03.00.24/03-broken-postscript.patch
deleted file mode 100644
index aa44549aca9b..000000000000
--- a/x11-misc/remind/files/03.00.24/03-broken-postscript.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur remind-03.00.24/src/rem2ps.c remind/src/rem2ps.c
---- remind-03.00.24/src/rem2ps.c 2005-09-30 05:29:32.000000000 +0200
-+++ remind/src/rem2ps.c 2006-01-15 15:48:26.000000000 +0100
-@@ -601,7 +601,6 @@
- PutChar(')');
- while(isspace((unsigned char)*s)) s++;
- if (!*s) {
-- printf("]\n");
- goto finish;
- }
- PutChar('(');
diff --git a/x11-misc/remind/files/03.00.24/03-tkremind-no-newlines.patch b/x11-misc/remind/files/03.00.24/03-tkremind-no-newlines.patch
deleted file mode 100644
index 6ae9e51172a5..000000000000
--- a/x11-misc/remind/files/03.00.24/03-tkremind-no-newlines.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -Naur remind-03.00.24/scripts/tkremind remind/scripts/tkremind
---- remind-03.00.24/scripts/tkremind 2005-04-14 19:34:34.000000000 +0200
-+++ remind/scripts/tkremind 2006-01-15 15:50:55.000000000 +0100
-@@ -1240,7 +1240,8 @@
- lappend ans "-global-$winstem" [eval set $winstem]
- }
- "Entry" {
-- lappend ans "-entry-$winstem" [$win get]
-+ # Do not put newlines in the reminder files
-+ lappend ans "-entry-$winstem" [string map -nocase {"\n" " "} [$win get]]
- }
- }
- }
-@@ -1519,7 +1520,8 @@
- regsub -- {^-stdin-\([0-9]*\): } $err {} err
- error "Error from Remind: $err"
- }
-- append rem " MSG $body"
-+ # Do not include newline characters after MSG
-+ append rem " MSG " [string map -nocase {"\n" " "} $body]
- return $rem
- }
-
diff --git a/x11-misc/remind/files/03.00.24/04-rem-cmd.patch b/x11-misc/remind/files/03.00.24/04-rem-cmd.patch
deleted file mode 100644
index 475f06da4e38..000000000000
--- a/x11-misc/remind/files/03.00.24/04-rem-cmd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur remind-03.00.24/src/dorem.c remind/src/dorem.c
---- remind-03.00.24/src/dorem.c 2005-11-20 02:26:59.000000000 +0100
-+++ remind/src/dorem.c 2006-01-15 15:55:28.000000000 +0100
-@@ -880,7 +880,7 @@
- }
- }
- }
-- if (l >= 0 && DBufPutc(&execBuffer, cmd[l]) != OK) {
-+ if (l!=(i-1) && l >= 0 && DBufPutc(&execBuffer, cmd[l]) != OK) {
- r = E_NO_MEM;
- goto finished;
- }
diff --git a/x11-misc/remind/remind-03.00.24.ebuild b/x11-misc/remind/remind-03.00.24.ebuild
deleted file mode 100644
index 589684852340..000000000000
--- a/x11-misc/remind/remind-03.00.24.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/remind-03.00.24.ebuild,v 1.5 2007/08/02 13:07:27 uberlord Exp $
-
-inherit eutils
-
-DESCRIPTION="Ridiculously functional reminder program"
-HOMEPAGE="http://www.roaringpenguin.com/penguin/open_source_remind.php"
-SRC_URI="http://www.roaringpenguin.com/penguin/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86 ~x86-fbsd"
-IUSE="X"
-
-RDEPEND="X? ( dev-lang/tk )"
-
-src_unpack() {
- unpack "${A}"
- epatch "${FILESDIR}/${PV}/01-optional-filename.patch"
- epatch "${FILESDIR}/${PV}/03-broken-postscript.patch"
- epatch "${FILESDIR}/${PV}/03-tkremind-no-newlines.patch"
- epatch "${FILESDIR}/${PV}/04-rem-cmd.patch"
-}
-
-src_install() {
- # stupid broken makefile...
- einstall || die "first einstall failed"
- dobin www/rem2html
-
- dodoc README ACKNOWLEDGEMENTS COPYRIGHT WINDOWS doc/README.UNIX \
- doc/WHATSNEW* www/README.*
-}
diff --git a/x11-misc/remind/remind-03.01.03.ebuild b/x11-misc/remind/remind-03.01.05.ebuild
index 1b80da16fad6..32c425875c00 100644
--- a/x11-misc/remind/remind-03.01.03.ebuild
+++ b/x11-misc/remind/remind-03.01.05.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/remind-03.01.03.ebuild,v 1.1 2007/10/17 15:25:03 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/remind-03.01.05.ebuild,v 1.1 2008/04/17 10:39:58 tove Exp $
MY_P=${P/_beta/-BETA-}
DESCRIPTION="Ridiculously functional reminder program"
-HOMEPAGE="http://www.roaringpenguin.com/en/penguin/openSourceProducts/remind"
+HOMEPAGE="http://www.roaringpenguin.com/products/remind"
SRC_URI="http://www.roaringpenguin.com/files/download/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -32,11 +32,3 @@ src_install() {
"${D}"/usr/bin/cm2rem* "${D}"/usr/share/man/man1/cm2rem*
fi
}
-
-pkg_postinst() {
- elog "Some changes from 03.00.24:"
- elog "A reminders filename must be supplied to 'remind'. It is no longer"
- elog "optional. You can use 'rem' instead."
- elog "The environment variable that may contain your default reminders"
- elog "filename was renamed from DOT_REMINDERS to DOTREMINDERS."
-}