summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-11-02 17:29:44 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-11-02 17:29:44 +0000
commit0a794287119cdf96a2ffb21a807195a47dc7a421 (patch)
treee787917787211145abc60ba5b7733baf51c91369 /x11-misc/pcmanfm
parentVersion bump. This is pretty much identical to 1.0.2 (diff)
downloadgentoo-2-0a794287119cdf96a2ffb21a807195a47dc7a421.tar.gz
gentoo-2-0a794287119cdf96a2ffb21a807195a47dc7a421.tar.bz2
gentoo-2-0a794287119cdf96a2ffb21a807195a47dc7a421.zip
Version bump. This is pretty much identical to 1.0.2
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'x11-misc/pcmanfm')
-rw-r--r--x11-misc/pcmanfm/ChangeLog7
-rw-r--r--x11-misc/pcmanfm/pcmanfm-1.1.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/x11-misc/pcmanfm/ChangeLog b/x11-misc/pcmanfm/ChangeLog
index a3ee9c1d2d52..a21731211c8e 100644
--- a/x11-misc/pcmanfm/ChangeLog
+++ b/x11-misc/pcmanfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/pcmanfm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/ChangeLog,v 1.87 2012/11/02 17:16:14 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/ChangeLog,v 1.88 2012/11/02 17:29:44 hwoarang Exp $
+
+*pcmanfm-1.1.0 (02 Nov 2012)
+
+ 02 Nov 2012; Markos Chandras <hwoarang@gentoo.org> +pcmanfm-1.1.0.ebuild:
+ Version bump. This is pretty much identical to 1.0.2
*pcmanfm-1.0.2 (02 Nov 2012)
diff --git a/x11-misc/pcmanfm/pcmanfm-1.1.0.ebuild b/x11-misc/pcmanfm/pcmanfm-1.1.0.ebuild
new file mode 100644
index 000000000000..730c06bc5db0
--- /dev/null
+++ b/x11-misc/pcmanfm/pcmanfm-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/pcmanfm/pcmanfm-1.1.0.ebuild,v 1.1 2012/11/02 17:29:44 hwoarang Exp $
+
+EAPI="4"
+inherit eutils fdo-mime
+
+MY_PV="${PV/_/}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Fast lightweight tabbed filemanager"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.16:2
+ >=lxde-base/menu-cache-0.3.2
+ x11-misc/shared-mime-info
+ >=x11-libs/libfm-${PV}
+ virtual/eject"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( AUTHORS )
+
+src_configure() {
+ strip-linguas -i "${S}/po"
+ econf --sysconfdir=/etc $(use_enable debug)
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+
+ elog 'PCmanFM can optionally support the menu://applications/ location.'
+ elog 'You should install lxde-base/lxmenu-data for that functionality.'
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}